What is the oldest supported MacOS for Ruby 3.0.0?

Hi,

What is the oldest supported MacOS for Ruby 3.0.0?

I'm running Sierra on Mac Book Pro (late 2014) laptop and 2.7.2p137 installs
but not ruby-3.0.0-preview1 or ruby-3.0.0-preview2.
I tried both rvm and adsl.

Where do I report the issue if it should work?

Thanks,
@jasnow on GitHub

Hi,

What error did you got?

···

Em sáb., 19 de dez. de 2020 às 14:17, Al Snow <jasnow@hotmail.com> escreveu:

Hi,

What is the oldest supported MacOS for Ruby 3.0.0?

I'm running Sierra on Mac Book Pro (late 2014) laptop and 2.7.2p137
installs
but not ruby-3.0.0-preview1 or ruby-3.0.0-preview2.
I tried both rvm and adsl.

Where do I report the issue if it should work?

Thanks,
@jasnow on GitHub

Unsubscribe: <mailto:ruby-talk-request@ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-talk>

--
Fellipe Fingoli

I wrote it up as https://github.com/rvm/rvm/issues/5012 for preview2
and added a comment to https://github.com/rvm/rvm/issues/5014 for rc1 today.
My example repo is https://github.com/jasnow/empty30 and change 2.7.2 to ruby-3.0.0-preview2 or ruby-3.0.0-rc1 .
Also add a .rvmrc file with "rvm use ruby-3.0-rc1@ruby3.0-no-rails --create" in it.

Thanks

···

________________________________
From: ruby-talk <ruby-talk-bounces@ruby-lang.org> on behalf of Fellipe Fingoli <fellipe.fingoli@gmail.com>
Sent: Sunday, December 20, 2020 2:08 PM
To: Ruby users <ruby-talk@ruby-lang.org>
Subject: Re: What is the oldest supported MacOS for Ruby 3.0.0?

Hi,

What error did you got?

Em sáb., 19 de dez. de 2020 às 14:17, Al Snow <jasnow@hotmail.com<mailto:jasnow@hotmail.com>> escreveu:
Hi,

What is the oldest supported MacOS for Ruby 3.0.0?

I'm running Sierra on Mac Book Pro (late 2014) laptop and 2.7.2p137 installs
but not ruby-3.0.0-preview1 or ruby-3.0.0-preview2.
I tried both rvm and adsl.

Where do I report the issue if it should work?

Thanks,
@jasnow on GitHub

Unsubscribe: <mailto:ruby-talk-request@ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-talk>

--
Fellipe Fingoli

You need C compilers installed. Try to run:

xcode-select --install

on Terminal. You need to be su to run that command.

···

Em dom., 20 de dez. de 2020 às 16:43, Al Snow <jasnow@hotmail.com> escreveu:

I wrote it up as https://github.com/rvm/rvm/issues/5012 for preview2
and added a comment to https://github.com/rvm/rvm/issues/5014 for rc1
today.
My example repo is https://github.com/jasnow/empty30 and change 2.7.2 to
ruby-3.0.0-preview2 or ruby-3.0.0-rc1 .
Also add a .rvmrc file with "rvm use ruby-3.0-rc1@ruby3.0-no-rails
--create" in it.

Thanks

------------------------------
*From:* ruby-talk <ruby-talk-bounces@ruby-lang.org> on behalf of Fellipe
Fingoli <fellipe.fingoli@gmail.com>
*Sent:* Sunday, December 20, 2020 2:08 PM
*To:* Ruby users <ruby-talk@ruby-lang.org>
*Subject:* Re: What is the oldest supported MacOS for Ruby 3.0.0?

Hi,

What error did you got?

Em sáb., 19 de dez. de 2020 às 14:17, Al Snow <jasnow@hotmail.com> > escreveu:

Hi,

What is the oldest supported MacOS for Ruby 3.0.0?

I'm running Sierra on Mac Book Pro (late 2014) laptop and 2.7.2p137
installs
but not ruby-3.0.0-preview1 or ruby-3.0.0-preview2.
I tried both rvm and adsl.

Where do I report the issue if it should work?

Thanks,
@jasnow on GitHub

Unsubscribe: <mailto:ruby-talk-request@ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-talk>

--
Fellipe Fingoli

Unsubscribe: <mailto:ruby-talk-request@ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-talk>

--
Fellipe Fingoli

Okay - I ran "sudo xcode-select --install" and got:
Password:
xcode-select: error: command line tools are already installed,
use "Software Update" to install updates

Then I checked "Software Updates" and found that Xcode 12.3 is incompatible with
my version of MacOS, so I'm guessing that the ruby codebase is using some
language features that would introduce still "xcode-select 2347".

Thanks for your help

s

···

________________________________
From: ruby-talk <ruby-talk-bounces@ruby-lang.org> on behalf of Fellipe Fingoli <fellipe.fingoli@gmail.com>
Sent: Sunday, December 20, 2020 10:22 PM
To: Ruby users <ruby-talk@ruby-lang.org>
Subject: Re: What is the oldest supported MacOS for Ruby 3.0.0?

You need C compilers installed. Try to run:

xcode-select --install

on Terminal. You need to be su to run that command.

Em dom., 20 de dez. de 2020 às 16:43, Al Snow <jasnow@hotmail.com<mailto:jasnow@hotmail.com>> escreveu:
I wrote it up as https://github.com/rvm/rvm/issues/5012 for preview2
and added a comment to https://github.com/rvm/rvm/issues/5014 for rc1 today.
My example repo is https://github.com/jasnow/empty30 and change 2.7.2 to ruby-3.0.0-preview2 or ruby-3.0.0-rc1 .
Also add a .rvmrc file with "rvm use ruby-3.0-rc1@ruby3.0-no-rails --create" in it.

Thanks

________________________________
From: ruby-talk <ruby-talk-bounces@ruby-lang.org<mailto:ruby-talk-bounces@ruby-lang.org>> on behalf of Fellipe Fingoli <fellipe.fingoli@gmail.com<mailto:fellipe.fingoli@gmail.com>>
Sent: Sunday, December 20, 2020 2:08 PM
To: Ruby users <ruby-talk@ruby-lang.org<mailto:ruby-talk@ruby-lang.org>>
Subject: Re: What is the oldest supported MacOS for Ruby 3.0.0?

Hi,

What error did you got?

Em sáb., 19 de dez. de 2020 às 14:17, Al Snow <jasnow@hotmail.com<mailto:jasnow@hotmail.com>> escreveu:
Hi,

What is the oldest supported MacOS for Ruby 3.0.0?

I'm running Sierra on Mac Book Pro (late 2014) laptop and 2.7.2p137 installs
but not ruby-3.0.0-preview1 or ruby-3.0.0-preview2.
I tried both rvm and adsl.

Where do I report the issue if it should work?

Thanks,
@jasnow on GitHub

Unsubscribe: <mailto:ruby-talk-request@ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-talk>

--
Fellipe Fingoli

Unsubscribe: <mailto:ruby-talk-request@ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-talk>

--
Fellipe Fingoli

Could be that. Unfortunately I don't have a Mac to help you more :frowning:

···

Em seg., 21 de dez. de 2020 às 10:26, Al Snow <jasnow@hotmail.com> escreveu:

Okay - I ran "sudo xcode-select --install" and got:
Password:
xcode-select: error: command line tools are already installed,
use "Software Update" to install updates

Then I checked "Software Updates" and found that Xcode 12.3 is
incompatible with
my version of MacOS, so I'm guessing that the ruby codebase is using some
language features that would introduce still "xcode-select 2347".

Thanks for your help

s
------------------------------
*From:* ruby-talk <ruby-talk-bounces@ruby-lang.org> on behalf of Fellipe
Fingoli <fellipe.fingoli@gmail.com>
*Sent:* Sunday, December 20, 2020 10:22 PM
*To:* Ruby users <ruby-talk@ruby-lang.org>
*Subject:* Re: What is the oldest supported MacOS for Ruby 3.0.0?

You need C compilers installed. Try to run:

xcode-select --install

on Terminal. You need to be su to run that command.

Em dom., 20 de dez. de 2020 às 16:43, Al Snow <jasnow@hotmail.com> > escreveu:

I wrote it up as https://github.com/rvm/rvm/issues/5012 for preview2
and added a comment to https://github.com/rvm/rvm/issues/5014 for rc1
today.
My example repo is https://github.com/jasnow/empty30 and change 2.7.2 to
ruby-3.0.0-preview2 or ruby-3.0.0-rc1 .
Also add a .rvmrc file with "rvm use ruby-3.0-rc1@ruby3.0-no-rails
--create" in it.

Thanks

------------------------------
*From:* ruby-talk <ruby-talk-bounces@ruby-lang.org> on behalf of Fellipe
Fingoli <fellipe.fingoli@gmail.com>
*Sent:* Sunday, December 20, 2020 2:08 PM
*To:* Ruby users <ruby-talk@ruby-lang.org>
*Subject:* Re: What is the oldest supported MacOS for Ruby 3.0.0?

Hi,

What error did you got?

Em sáb., 19 de dez. de 2020 às 14:17, Al Snow <jasnow@hotmail.com> > escreveu:

Hi,

What is the oldest supported MacOS for Ruby 3.0.0?

I'm running Sierra on Mac Book Pro (late 2014) laptop and 2.7.2p137
installs
but not ruby-3.0.0-preview1 or ruby-3.0.0-preview2.
I tried both rvm and adsl.

Where do I report the issue if it should work?

Thanks,
@jasnow on GitHub

Unsubscribe: <mailto:ruby-talk-request@ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-talk>

--
Fellipe Fingoli

Unsubscribe: <mailto:ruby-talk-request@ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-talk>

--
Fellipe Fingoli

Unsubscribe: <mailto:ruby-talk-request@ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-talk>

--
Fellipe Fingoli

Fellipe

I will stay with 2.7.2+ for now and decide if do VM or new computer. Apple upgrades across multiple versions has been dangerous in the past.

Thanks for you,
Al

···

________________________________
From: ruby-talk <ruby-talk-bounces@ruby-lang.org> on behalf of Fellipe Fingoli <fellipe.fingoli@gmail.com>
Sent: Monday, December 21, 2020 2:10 PM
To: Ruby users <ruby-talk@ruby-lang.org>
Subject: Re: What is the oldest supported MacOS for Ruby 3.0.0?

Could be that. Unfortunately I don't have a Mac to help you more :frowning:

Em seg., 21 de dez. de 2020 às 10:26, Al Snow <jasnow@hotmail.com<mailto:jasnow@hotmail.com>> escreveu:
Okay - I ran "sudo xcode-select --install" and got:
Password:
xcode-select: error: command line tools are already installed,
use "Software Update" to install updates

Then I checked "Software Updates" and found that Xcode 12.3 is incompatible with
my version of MacOS, so I'm guessing that the ruby codebase is using some
language features that would introduce still "xcode-select 2347".

Thanks for your help

s
________________________________
From: ruby-talk <ruby-talk-bounces@ruby-lang.org<mailto:ruby-talk-bounces@ruby-lang.org>> on behalf of Fellipe Fingoli <fellipe.fingoli@gmail.com<mailto:fellipe.fingoli@gmail.com>>
Sent: Sunday, December 20, 2020 10:22 PM
To: Ruby users <ruby-talk@ruby-lang.org<mailto:ruby-talk@ruby-lang.org>>
Subject: Re: What is the oldest supported MacOS for Ruby 3.0.0?

You need C compilers installed. Try to run:

xcode-select --install

on Terminal. You need to be su to run that command.

Em dom., 20 de dez. de 2020 às 16:43, Al Snow <jasnow@hotmail.com<mailto:jasnow@hotmail.com>> escreveu:
I wrote it up as https://github.com/rvm/rvm/issues/5012 for preview2
and added a comment to https://github.com/rvm/rvm/issues/5014 for rc1 today.
My example repo is https://github.com/jasnow/empty30 and change 2.7.2 to ruby-3.0.0-preview2 or ruby-3.0.0-rc1 .
Also add a .rvmrc file with "rvm use ruby-3.0-rc1@ruby3.0-no-rails --create" in it.

Thanks

________________________________
From: ruby-talk <ruby-talk-bounces@ruby-lang.org<mailto:ruby-talk-bounces@ruby-lang.org>> on behalf of Fellipe Fingoli <fellipe.fingoli@gmail.com<mailto:fellipe.fingoli@gmail.com>>
Sent: Sunday, December 20, 2020 2:08 PM
To: Ruby users <ruby-talk@ruby-lang.org<mailto:ruby-talk@ruby-lang.org>>
Subject: Re: What is the oldest supported MacOS for Ruby 3.0.0?

Hi,

What error did you got?

Em sáb., 19 de dez. de 2020 às 14:17, Al Snow <jasnow@hotmail.com<mailto:jasnow@hotmail.com>> escreveu:
Hi,

What is the oldest supported MacOS for Ruby 3.0.0?

I'm running Sierra on Mac Book Pro (late 2014) laptop and 2.7.2p137 installs
but not ruby-3.0.0-preview1 or ruby-3.0.0-preview2.
I tried both rvm and adsl.

Where do I report the issue if it should work?

Thanks,
@jasnow on GitHub

Unsubscribe: <mailto:ruby-talk-request@ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-talk>

--
Fellipe Fingoli

Unsubscribe: <mailto:ruby-talk-request@ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-talk>

--
Fellipe Fingoli

Unsubscribe: <mailto:ruby-talk-request@ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-talk>

--
Fellipe Fingoli