Yesterday I just convert my application to the new Test::Unit.
After reading some ruby-talk archive some of them already in
Nat’s TODO list but I include them as a reminder.
Here is my impression:
- There should be a warning about the rename of setup to set_up.
Is there any way to issue a warning from a library? like Perl warn.
- What flunk means? Maybe it should renamed to assert_fail
(like Runit) or any other better name.
I also need assert_ok(message = “”) so my test is in symmetry.
- I prefer the RUnit Console Test Runner, it is more verbose
and the dot distract me from the Failure/Error message.
If you still prefer the dot then make the verbose mode
an option so I could run my test like this
- Remove the ellipsis (…) in “Started…”
- Rather than
Failure occurred in test_method(TestClass) [./t.rb:20]: Some_long_msg
Failure in TestClass#test_method [./t.rb:20]:
Anyway, thank you Nat for a wonderful unit test framework.