[ANN] Ruby-GNOME 0.29 is out!


(Masao Mutoh) #1

Hi,

Ruby-GNOME 0.29, Ruby-GTK 0.29 is now available!

Ruby-GNOME is a set of Ruby language bindings for
the GNOME 1.x development environment.
And Ruby-GTK is for GTK+ 1.2.x.

http://sourceforge.net/project/showfiles.php?group_id=35786

Enjoy!

Overview of Changes

···

===================
libglade

  • support gnome in default.
  • add GladeXML#widget, #widget_by_long_name, #connect
    (aliases of GladeXML#getWidget, #getWidgetByLongName, #doConnect).

Ruby-GTK

  • Implement Gdk::Window#copy_area, #register_dnd,
    #override_redirect, #shape_combine_mask, #set_child_shapes,
    #merge_child_shapes, #set_static_gravities, #set_hints, #set_title,
    #set_colormap, #position, #visual, #colormap, #window_type, #origin,
    #deskrelative_origin, #parent, #toplevel, #children,
    #set_transient_for, #set_role, #set_group, #toplevels,
    #property_change, #propery_get, #propery_delete.
  • Minor improvements Gtk::CTreeNode#==.
  • Fix bug in extconf.rb.


.:% Masao Mutohmutoh@highway.ne.jp