Why do some gems require 'rubygems'?

(Wybo Dekker) #1

Some gems, like RMagick, can be loaded with just 1 require,
others, like rio, need require 'rubygems' first.
Why is that?

···

--
Wybo

(Wybo Dekker) #2

Wybo Dekker wrote:
  > Some gems, like RMagick, can be loaded with just 1 require,
  > others, like rio, need require 'rubygems' first.
  > Why is that?

I finally found the solution in http://docs.rubygems.org/read/chapter/3#page70:

export RUBYOPT=rubygems

Thanks.

···

--
Wybo