Unable to preload "rbconfig" in my irb session

I'm using Ruby 1.9.2 with Windows XP as host, I ran the command

irb --simple-prompt -rrbconfig

from the command line and got an error stating:
"E:/Ruby192/lib/ruby/site_ruby/1.9.1/rbreadline.rb:2043:in ``': No such
file or directory - stty -a (Errno::ENOENT)"

I've attached the complete error statement along with the post, please
help.

Thanks,
Sandeep

···

--
Posted via http://www.ruby-forum.com/.

I'm using Ruby 1.9.2 with Windows XP as host, I ran the command

irb --simple-prompt -rrbconfig

from the command line and got an error stating:
"E:/Ruby192/lib/ruby/site_ruby/1.9.1/rbreadline.rb:2043:in ``': No such
file or directory - stty -a (Errno::ENOENT)"

I've attached the complete error statement along with the post, please
help.

Have you installed cygwin or cygwin installation bundled with E text
editor?

Are you using a normal command prompt?

What is the output of "SET TERM" ?

This has nothing to do with rbconfig but instead if the rb-readline
(pure-ruby readline) component that is bundled with Ruby 1.9.2-p0
provided by RubyInstaller.

The only way for stty be invoked is an incorrect environment variable
or bash/sh installation interfering with rb-readline.

I'm not able to recreate this:

C:\Users\Luis>ruby -v
ruby 1.9.2p0 (2010-08-18) [i386-mingw32]

C:\Users\Luis>set TERM
Environment variable TERM not defined

C:\Users\Luis>irb --simple-prompt -rrbconfig

Please provide that information and also open a bug report in rb-
readline issue tracker:

···

On Oct 17, 5:58 am, "Sandeep K." <uniqueemba...@gmail.com> wrote:

--
Luis Lavena

C:\Documents and Settings\Scarlet Pimpernel>ruby -v
ruby 1.9.2p0 (2010-08-18) [i386-mingw32]

C:\Documents and Settings\Scarlet Pimpernel>set TERM
TERM=nutc
TERMCAP=E:\RATIONAL\RATION~1\NUTCROOT\etc\termcap
TERMINFO=E:\RATIONAL\RATION~1\NUTCROOT\usr\lib\terminfo

I'm using a normal command prompt and as I'm yet a beginner I do not
know what you mean by: "This has nothing to do with rbconfig but instead
if the rb-readline (pure-ruby readline) component that is bundled with
Ruby 1.9.2-p0
provided by RubyInstaller."

I do not exactly know what my problem is, I'm sorry to say this but
that's how my position is.

Thanks,
Sandeep.

···

--
Posted via http://www.ruby-forum.com/.

C:\Documents and Settings\Scarlet Pimpernel>ruby -v
ruby 1.9.2p0 (2010-08-18) [i386-mingw32]

C:\Documents and Settings\Scarlet Pimpernel>set TERM
TERM=nutc
TERMCAP=E:\RATIONAL\RATION~1\NUTCROOT\etc\termcap
TERMINFO=E:\RATIONAL\RATION~1\NUTCROOT\usr\lib\terminfo

I'm using a normal command prompt and as I'm yet a beginner I do not
know what you mean by: "The only way for stty be invoked is an incorrect
environment variable or bash/sh installation interfering with
rb-readline."

Thanks,
Sandeep.

···

--
Posted via http://www.ruby-forum.com/.

i have unset the TERM.

Now, when i execute the "set TERM" command, i get:

C:\Documents and Settings\Scarlet Pimpernel>set TERM
Environment variable TERM not defined

Please provide me with the correct environment variable settings.

Thanks,
Sandeep.

···

--
Posted via http://www.ruby-forum.com/.

does that mean, I should uninstall my current version of the ruby and
opt for an older one or is there a better way out?

Thanks,
Sandeep

···

--
Posted via http://www.ruby-forum.com/.

C:\Documents and Settings\Scarlet Pimpernel>ruby -v
ruby 1.9.2p0 (2010-08-18) [i386-mingw32]

C:\Documents and Settings\Scarlet Pimpernel>set TERM
TERM=nutc
TERMCAP=E:\RATIONAL\RATION~1\NUTCROOT\etc\termcap
TERMINFO=E:\RATIONAL\RATION~1\NUTCROOT\usr\lib\terminfo

Can you unset TERM?

I searched a bit looking for what could be considered a "nutc"
terminal option and nothing was found. Also dunno what could have set
that for you.

As I indicated in the ticket, please unset it:

SET TERM=

And try again.

I'm using a normal command prompt and as I'm yet a beginner I do not
know what you mean by: "The only way for stty be invoked is an incorrect
environment variable or bash/sh installation interfering with
rb-readline."

stty is a utility in *nix systems used to determine terminal
capabilities. Due the weird terminal setting you have, it is trying to
use stty which is not found.

I mentioned that a cygwin installation or something is interfering in
your system, which with the above that you provided proven correct.

···

On Oct 18, 1:45 pm, "Sandeep K." <uniqueemba...@gmail.com> wrote:

--
Luis Lavena

Provided instructions for you in the rb-readline ticket:

Will perform a release and instructions soon.

···

On Oct 19, 10:43 am, "Sandeep K." <uniqueemba...@gmail.com> wrote:

does that mean, I should uninstall my current version of the ruby and
opt for an older one or is there a better way out?

--
Luis Lavena

Hi,

C:\Documents and Settings\Scarlet Pimpernel>ruby -v
ruby 1.9.2p0 (2010-08-18) [i386-mingw32]

C:\Documents and Settings\Scarlet Pimpernel>set TERM
TERM=nutc
TERMCAP=E:\RATIONAL\RATION~1\NUTCROOT\etc\termcap
TERMINFO=E:\RATIONAL\RATION~1\NUTCROOT\usr\lib\terminfo

Can you unset TERM?

I searched a bit looking for what could be considered a "nutc"
terminal option and nothing was found. Also dunno what could have set
that for you.

As I indicated in the ticket, please unset it:

SET TERM=

And try again.

I'm using a normal command prompt and as I'm yet a beginner I do not
know what you mean by: "The only way for stty be invoked is an incorrect
environment variable or bash/sh installation interfering with
rb-readline."

stty is a utility in *nix systems used to determine terminal
capabilities. Due the weird terminal setting you have, it is trying to
use stty which is not found.

I mentioned that a cygwin installation or something is interfering in
your system, which with the above that you provided proven correct.

It seems that the rbreadline.rb distributed with rubyinstaller 1.9.2
is not a bug fixed version.

rubyinstaller 1.9.2 version:

def no_terminal?
    term = ENV["TERM"]
    term.nil? || (term == 'dumb') || (term == 'cygwin' &&
RUBY_PLATFORM =~ /mswin|mingw/)
  end

the latest github version:

  def no_terminal?
    term = ENV["TERM"]
    term.nil? || (term == 'dumb') || (RUBY_PLATFORM =~ /mswin|mingw/)
  end

Regards,
Park Heesob

Regards,
Park Heesob

···

2010/10/19 Luis Lavena <luislavena@gmail.com>:

On Oct 18, 1:45 pm, "Sandeep K." <uniqueemba...@gmail.com> wrote:

Park, do you consider current rb-readline is candidate for a release?

That way I can provide packages and installation instructions to
users.

Thank you

···

On Oct 18, 10:09 pm, Heesob Park <pha...@gmail.com> wrote:

Hi,

2010/10/19 Luis Lavena <luislav...@gmail.com>:

> On Oct 18, 1:45 pm, "Sandeep K." <uniqueemba...@gmail.com> wrote:
>> C:\Documents and Settings\Scarlet Pimpernel>ruby -v
>> ruby 1.9.2p0 (2010-08-18) [i386-mingw32]

>> C:\Documents and Settings\Scarlet Pimpernel>set TERM
>> TERM=nutc
>> TERMCAP=E:\RATIONAL\RATION~1\NUTCROOT\etc\termcap
>> TERMINFO=E:\RATIONAL\RATION~1\NUTCROOT\usr\lib\terminfo

> Can you unset TERM?

> I searched a bit looking for what could be considered a "nutc"
> terminal option and nothing was found. Also dunno what could have set
> that for you.

> As I indicated in the ticket, please unset it:

> SET TERM=

> And try again.

>> I'm using a normal command prompt and as I'm yet a beginner I do not
>> know what you mean by: "The only way for stty be invoked is an incorrect
>> environment variable or bash/sh installation interfering with
>> rb-readline."

> stty is a utility in *nix systems used to determine terminal
> capabilities. Due the weird terminal setting you have, it is trying to
> use stty which is not found.

> I mentioned that a cygwin installation or something is interfering in
> your system, which with the above that you provided proven correct.

It seems that the rbreadline.rb distributed with rubyinstaller 1.9.2
is not a bug fixed version.

--
Luis Lavena

Hi,

Hi,

>> C:\Documents and Settings\Scarlet Pimpernel>ruby -v
>> ruby 1.9.2p0 (2010-08-18) [i386-mingw32]

It seems that the rbreadline.rb distributed with rubyinstaller 1.9.2
is not a bug fixed version.

Park, do you consider current rb-readline is candidate for a release?

Yes, at least, the current version is better than the installer
included version.

That way I can provide packages and installation instructions to
users.

Regards,
Park Heesob

···

2010/10/19 Luis Lavena <luislavena@gmail.com>:

On Oct 18, 10:09 pm, Heesob Park <pha...@gmail.com> wrote:

2010/10/19 Luis Lavena <luislav...@gmail.com>:
> On Oct 18, 1:45 pm, "Sandeep K." <uniqueemba...@gmail.com> wrote: