Trying to make rails work

(Mohammad Khan) #1

[mkhan@localhost ~]$ ruby -v
ruby 1.8.2 (2004-12-25) [i386-linux]
[mkhan@localhost ~]$ gem -v
0.8.1
[mkhan@localhost ~]$ rails -v
/usr/lib/site_ruby/1.8/rubygems.rb:116:in `activate': (Gem::LoadError)
Could not find RubyGem rails (> 0)
        from /usr/lib/site_ruby/1.8/rubygems.rb:34:in `require_gem'
        from /usr/local/bin/rails:18
[mkhan@localhost ~]$ rails demo
/usr/lib/site_ruby/1.8/rubygems.rb:116:in `activate': (Gem::LoadError)
Could not find RubyGem rails (> 0)
        from /usr/lib/site_ruby/1.8/rubygems.rb:34:in `require_gem'
        from /usr/local/bin/rails:18
[mkhan@localhost ~]$

Not sure, where is my mistake..
Please help to find it.

Thanks,
Mohammad

(Kevin Olbrich) #2

Try this first..

gem install rails

···

-----Original Message-----
From: Mohammad Khan [mailto:mkhan@lextranet.com]
Sent: Wednesday, August 10, 2005 05:02 PM
To: ruby-talk ML
Subject: trying to make rails work

[mkhan@localhost ~]$ ruby -v
ruby 1.8.2 (2004-12-25) [i386-linux]
[mkhan@localhost ~]$ gem -v
0.8.1
[mkhan@localhost ~]$ rails -v /usr/lib/site_ruby/1.8/rubygems.rb:116:in
`activate': (Gem::LoadError) Could not find RubyGem rails (> 0)
        from /usr/lib/site_ruby/1.8/rubygems.rb:34:in `require_gem'
        from /usr/local/bin/rails:18
[mkhan@localhost ~]$ rails demo /usr/lib/site_ruby/1.8/rubygems.rb:116:in
`activate': (Gem::LoadError) Could not find RubyGem rails (> 0)
        from /usr/lib/site_ruby/1.8/rubygems.rb:34:in `require_gem'
        from /usr/local/bin/rails:18
[mkhan@localhost ~]$

Not sure, where is my mistake..
Please help to find it.

Thanks,
Mohammad