Troubles with the installation of RAILS

(Jan Meskens) #1

Hello,

I have the following error when I try to run RAILS (on ubuntu linux).

jan@meskens:~/ruby$ rails /home/jan/ruby/test
/usr/lib/ruby/gems/1.8/gems/activesupport-1.1.1/lib/active_support
/dependencies.rb:186:in `const_missing': uninitialized constant Base
(NameError)
from
/usr/lib/ruby/gems/1.8/gems/actionpack-1.9.1/lib/action_view.rb:30
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:18:in
'require__' from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:18:in
`require' from
/usr/lib/ruby/gems/1.8/gems/activesupport-1.1.1/lib/active_support
/dependencies.rb:200:in
`require' from
/usr/lib/ruby/gems/1.8/gems/actionpack-1.9.1/lib/action_controller.rb:54
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:18:in
`require__' from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:18:in
`require' from
/usr/lib/ruby/gems/1.8/gems/activesupport-1.1.1/lib/active_support
/dependencies.rb:200:in
`require' from /usr/local/lib/site_ruby/1.8/rubygems.rb:175:in
`activate' from /usr/local/lib/site_ruby/1.8/rubygems.rb:162:in
`activate' from /usr/local/lib/site_ruby/1.8/rubygems.rb:161:in
`each' from /usr/local/lib/site_ruby/1.8/rubygems.rb:161:in
`activate' from /usr/local/lib/site_ruby/1.8/rubygems.rb:37:in
`require_gem_with_options' from
/usr/local/lib/site_ruby/1.8/rubygems.rb:31:in `require_gem' from
/usr/bin/rails:17

Is there something I do wrong? I am totaly new in Ruby and Rails... .

(gilmae) #2

Jan Meskens wrote:

Hello,

I have the following error when I try to run RAILS (on ubuntu linux).

jan@meskens:~/ruby$ rails /home/jan/ruby/test
/usr/lib/ruby/gems/1.8/gems/activesupport-1.1.1/lib/active_support
/dependencies.rb:186:in `const_missing': uninitialized constant Base
(NameError)
from
/usr/lib/ruby/gems/1.8/gems/actionpack-1.9.1/lib/action_view.rb:30
Is there something I do wrong? I am totaly new in Ruby and Rails... .

I am getting this as well, and I know of at least one other getting the
same error.

Nobody on #rubyonrails seemed to know much about it though.

g.

(Jan Meskens) #3

I am getting this as well, and I know of at least one other getting the
same error.

Nobody on #rubyonrails seemed to know much about it though.

And have you fixed the error ? Or have you done something alternative to
avoid these errors.

Jan

(Andrew Stone) #4

I've got everything working on ubuntu without any problems. Did you
use wajig or apt-get to install ruby or did you build ruby? From the
paths it looks like a wajig install. Did you add links in your
/usr/local/bin for ruby and gem:

ls -ltr /usr/local/bin/
lrwxrwxrwx 1 root root 16 2005-08-03 13:12 ruby -> /usr/bin/ruby1.8
lrwxrwxrwx 1 root root 12 2005-08-03 13:23 gem -> /usr/bin/gem

I'm a relatively new to ruby/rails so I'm not sure if this has
anything to do with the problems you're getting. There was a previous
post on this list that went through the whole apache2 fcgi ruby/rails
setup that was very good and what I followed to get me up and running.

-andy

···

--
Andrew Stone

(gilmae) #5

Jan Meskens wrote:

And have you fixed the error ? Or have you done something alternative to
avoid these errors.

Sorry. I had posted between throwing up my hands in exasperation, and
seeking sleep.

g.

(Jan Meskens) #6

I've installed ruby with synaptec. Than I made a link for ruby in
/usr/local/bin. Gem I have installed with the command 'ruby setup.rb'.
Then I've done the following for installing rails :

# gem install rails --include-dependencies

At the end I've got the 'success' message, so it's installed.

# rails test

With this command I get the error as mentioned in the first post of me.

[error]
jan@meskens:~/ruby$ rails /home/jan/ruby/test
/usr/lib/ruby/gems/1.8/gems/activesupport-1.1.1/lib/active_support
/dependencies.rb:186:in `const_missing': uninitialized constant Base
(NameError)
from
/usr/lib/ruby/gems/1.8/gems/actionpack-1.9.1/lib/action_view.rb:30
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:18:in
'require__' from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:18:in
`require' from
/usr/lib/ruby/gems/1.8/gems/activesupport-1.1.1/lib/active_support
/dependencies.rb:200:in
`require' from
/usr/lib/ruby/gems/1.8/gems/actionpack-1.9.1/lib/action_controller.rb:54
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:18:in
`require__' from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:18:in
`require' from
/usr/lib/ruby/gems/1.8/gems/activesupport-1.1.1/lib/active_support
/dependencies.rb:200:in
`require' from /usr/local/lib/site_ruby/1.8/rubygems.rb:175:in
`activate' from /usr/local/lib/site_ruby/1.8/rubygems.rb:162:in
`activate' from /usr/local/lib/site_ruby/1.8/rubygems.rb:161:in
`each' from /usr/local/lib/site_ruby/1.8/rubygems.rb:161:in
`activate' from /usr/local/lib/site_ruby/1.8/rubygems.rb:37:in
`require_gem_with_options' from
/usr/local/lib/site_ruby/1.8/rubygems.rb:31:in `require_gem' from
/usr/bin/rails:17
[/error]

Jan

···

Op Mon, 15 Aug 2005 22:44:58 +0900, schreef Andrew Stone:

I've got everything working on ubuntu without any problems. Did you
use wajig or apt-get to install ruby or did you build ruby? From the
paths it looks like a wajig install. Did you add links in your
/usr/local/bin for ruby and gem:

(Andrew Stone) #7

I'm just throwing things out because I have no idea what the problem
may actually be...

What database are you using? If postgres did you do: gem install postgres-pr?

Are you using fcgi? Did you do: gem install fcgi? I've forgotten to
do this one a couple of time :frowning:

Here's a list of my gems for comparison:

*** LOCAL GEMS ***

actionmailer (1.0.1)
    Service layer for easy email delivery and testing.

actionpack (1.9.1)
    Web-flow and rendering framework putting the VC in MVC.

actionwebservice (0.8.1)
    Web service support for Action Pack.

activerecord (1.11.1)
    Implements the ActiveRecord pattern for ORM.

activesupport (1.1.1)
    Support and utility classes used by the Rails framework.

fcgi (0.8.6.1)
    FastCGI ruby binding.

login_generator (1.1.0)
    [Rails] Login generator.

postgres-pr (0.4.0)
    A pure Ruby interface to the PostgreSQL (>= 7.4) database

rails (0.13.1)
    Web-application framework with template engine, control-flow layer,
    and ORM.

rake (0.5.4)
    Ruby based make-like utility.

sources (0.0.1)
    This package provides download sources for remote gem installation

-andy

···

--
Andrew Stone

(Jan Meskens) #8

Hi,

Thanks for answering.

I've installed the things you mentioned but without result. Actually, It's
impossible to create a rails application, and thats my problem. I don't
have the opportunity to use fcgi or postgresql or ... . The execution of
the command 'rails applicationName' fails... .

Jan

···

Op Tue, 16 Aug 2005 00:52:19 +0900, schreef Andrew Stone:

I'm just throwing things out because I have no idea what the problem
may actually be...

What database are you using? If postgres did you do: gem install postgres-pr?

Are you using fcgi? Did you do: gem install fcgi? I've forgotten to
do this one a couple of time :frowning:

(Kevin Olbrich) #9

I assume you tried 'gem install rails'.....

···

-----Original Message-----
From: Jan Meskens [mailto:janmeskens@pandora.be]
Sent: Monday, August 15, 2005 12:31 PM
To: ruby-talk ML
Subject: Re: Troubles with the installation of RAILS

Op Tue, 16 Aug 2005 00:52:19 +0900, schreef Andrew Stone:

I'm just throwing things out because I have no idea what the problem
may actually be...

What database are you using? If postgres did you do: gem install
postgres-pr?

Are you using fcgi? Did you do: gem install fcgi? I've forgotten to
do this one a couple of time :frowning:

Hi,

Thanks for answering.

I've installed the things you mentioned but without result. Actually, It's
impossible to create a rails application, and thats my problem. I don't have
the opportunity to use fcgi or postgresql or ... . The execution of the
command 'rails applicationName' fails... .

Jan

(Andrew Stone) #10

Hmmm...it seems that your installation is missing something. So try:

wajig list-installed ruby

here is what i get from mine:

libbigdecimal-ruby1.8
libcurses-ruby1.8
libdbm-ruby1.8
libdl-ruby1.8
libdrb-ruby1.8
liberb-ruby1.8
libgdbm-ruby1.8
libiconv-ruby1.8
libopenssl-ruby1.8
libpty-ruby1.8
libracc-runtime-ruby1.8
libreadline-ruby1.8
librexml-ruby1.8
libruby1.8
libruby1.8-dbg
libsdbm-ruby1.8
libsoap-ruby1.8
libstrscan-ruby1.8
libsyslog-ruby1.8
libtest-unit-ruby1.8
libxmlrpc-ruby1.8
libyaml-ruby1.8
libzlib-ruby1.8
ruby1.8
ruby1.8-dev

If you didn't get any errors on the gem install of rails and you have
all the gems I listed then the only other place (I can think of) to
look is at your ruby installation. So check for the above listed
items and see if you are missing any of these...

Sorry for the guessing game from my end...

···

--
Andrew Stone

(Jan Meskens) #11

Yes,

The rails command is also found, but produces errors.

···

Op Tue, 16 Aug 2005 01:46:03 +0900, schreef Kevin Olbrich:

I assume you tried 'gem install rails'.....

(Jan Meskens) #12

If you didn't get any errors on the gem install of rails and you have
all the gems I listed then the only other place (I can think of) to
look is at your ruby installation. So check for the above listed
items and see if you are missing any of these...

Okay,

I've made my ruby installation exactly like yours, and have reinstalled my
rails. It seems to be better, I get a 'cleaner' error.

[error]
$>rails test

Rails requires Ruby version 1.8.2 (2004-12-25) or later.
    You're running 1.8.2 (2004-12-23); please upgrade to continue.
[/error]

Now I need to reinstall some things of ruby maybe...

(Andrew Stone) #13

Okay, that's an Ubuntu issue with their rails package...

It's an easy fix (look at bottom of page):

···

On 8/15/05, Jan Meskens <janmeskens@pandora.be> wrote:

> If you didn't get any errors on the gem install of rails and you have
> all the gems I listed then the only other place (I can think of) to
> look is at your ruby installation. So check for the above listed
> items and see if you are missing any of these...

Okay,

I've made my ruby installation exactly like yours, and have reinstalled my
rails. It seems to be better, I get a 'cleaner' error.

[error]
$>rails test

Rails requires Ruby version 1.8.2 (2004-12-25) or later.
    You're running 1.8.2 (2004-12-23); please upgrade to continue.
[/error]

Now I need to reinstall some things of ruby maybe...

--
Andrew Stone

(Andrew Stone) #14

Meant with their Ruby package...not Rails.

···

--
Andrew Stone

(Jan Meskens) #15

It's fixed !!

Thanx to all, now I can start rolling on rails !

···

Op Tue, 16 Aug 2005 07:05:15 +0900, schreef Andrew Stone:

Meant with their Ruby package...not Rails.

(Andrew Stone) #16

Excellent! Happy ruby rolling (or something like that) :slight_smile:

-andy

···

--
Andrew Stone