RubyCocoa problem: No such file to load -- osx/objc/cocoa

Hi Simon,

Barry

I figured this out. Below is the email I sent to the contact email for
RubyCocoa but I didn’t get any reply. Anyway, all you need do is open the
Framework project file in ProjectBuilder and clear the linking of
libruby-static by deselecting the check box. But this does mean that when
you build apps you will need to explicity link in libruby-static. Hope this
helps.

Thanks a lot for the input. It changed my situation, but I still have
problems.
First, I have to tell you I’ve never used PB before. I took your advice the
following way:

  1. In the RubyCocoa source directory, I ran ruby install.rb config
  2. I opened up the RubyCocoa framework project file in PB, and deselected
    the libruby-static
    entry I saw in the Files tab and closed PB.
  3. Back in the RubyCocoa, I ran ruby install.rb setup.
  4. I tried to run the RubyCocoa unit tests now, as explained on the
    RubyCocoa site. My results
    were different than before. Now, instead of the 'no such file to load’
    error, I got:

/Library/Frameworks/RubyCocoa.framework/Versions/A/Resources/ruby/osx/objc/oc_import.rb:61:in
’ns_inherited’: undefined method ‘ocid’ for nil:NilClass (NoMethodError)
from
/Library/Frameworks/RubyCocoa.framework/Versions/A/Resources/ruby/osx/objc/oc_import.rb:41:in
’inherited’
from ./tc_subclass.rb:14
from testall.rb:4:in 'require’
from testall.rb:4
from testall.rb:3:in 'each’
from testall.rb:3
Loaded suite testall
Started

Finished in 0.702701 seconds

5 tests, 8 assertions, 0 failures, 0 errors

  1. I went ahead and did sudo ruby install.rb install anyway. Afterward, I
    tried to run some examples. The fontnames.rb example runs fine; the
    sndplay.rb runs, but I don’t hear anything (also true for sndplay2.rb and
    speak.rb )

  2. Running the HelloWorld.rb gives me an undefined method error like the one
    I got running the unit tests.

  3. I also tried to build the CocoHako.app by editing the make file and
    linking with ruby-static. The build works but I’m unable to launch the app.

Can you see anything I’m doing that’s obviously wrong?

Thanks in advance for any help.

Regards,
Barry

···

STOP MORE SPAM with the new MSN 8 and get 2 months FREE*
http://join.msn.com/?page=features/junkmail