Ruby 1.9 Bug

(Pascal GUICHARD) #1

Hello,
not sure, that this list is the best one for my issue, in that case could
you redirect me ?
I tried to install ruby 1.9, and from that moment, gem (rubygems) is not
functionning anymore.
Hereby, included the errors I get.
Best regards.
P. Guichard

···

__________________________________________________________________________________________________________
$ ruby -v
ruby 1.9.0 (2005-08-15) [i386-cygwin]

Administrateur@pg /src/ruby19/ruby
$ gem list --remote

*** REMOTE GEMS ***
/usr/local/lib/ruby/site_ruby/1.9/rubygems.rb:204:in
`report_activate_error': Co
uld not find RubyGem sources (> 0.0.0) (Gem::LoadError)
from /usr/local/lib/ruby/site_ruby/1.9/rubygems.rb:141:in `activate'
from /usr/local/lib/ruby/site_ruby/1.9/rubygems.rb:37:in `require_gem_wi
th_options'
from /usr/local/lib/ruby/site_ruby/1.9/rubygems.rb:31:in `require_gem'
from /usr/local/lib/ruby/site_ruby/1.9/rubygems/remote_installer.rb:425:
in `sources'
from /usr/local/lib/ruby/site_ruby/1.9/rubygems/remote_installer.rb:435:
in `source_index_hash'
from /usr/local/lib/ruby/site_ruby/1.9/rubygems/remote_installer.rb:415:
in `search'
from /usr/local/lib/ruby/site_ruby/1.9/rubygems/gem_commands.rb:600:in `
execute'
from /usr/local/lib/ruby/site_ruby/1.9/rubygems/gem_commands.rb:683:in `
execute'
from /usr/local/lib/ruby/site_ruby/1.9/rubygems/command.rb:49:in `invoke
'
from /usr/local/lib/ruby/site_ruby/1.9/rubygems/cmd_manager.rb:94:in `pr
ocess_args'
from /usr/local/lib/ruby/site_ruby/1.9/rubygems/cmd_manager.rb:67:in `ru
n'
from /usr/local/lib/ruby/site_ruby/1.9/rubygems/gem_runner.rb:13:in `run
'
from /usr/local/bin/gem:17

Administrateur@pg /src/ruby19/ruby
$