RMagick Install Woes ;_;

Running Win7 64 bit

Having troubles installing RMagick. I was following the read me, and I
only got to the part where it tells you to type out "gem install rmagick
--local" and then I get the following error: "ERROR: Could not find a
valid gem 'rmagick' (>= 0) in any repository"

So... basically I'm not sure how to continue from here? I keep reading
that there are ruby header files that I may not have or if I really need
them.

If I do, I'm not sure where or how to get them.

Sorry for my nubness ;_;

I appreciate the help in advance, thanks!

···

--
Posted via http://www.ruby-forum.com/.

the --local is probably what's getting you. Remove it :slight_smile:

···

--
Posted via http://www.ruby-forum.com/.

I get this if I just type gem install rmagick

C:\Users\Pierre>gem install rmagick
Building native extensions. This could take a while...
ERROR: Error installing rmagick:
        ERROR: Failed to build gem native extension.

C:/Ruby/bin/ruby.exe extconf.rb

···

+----------------------------------------------------------------------------+

This rmagick gem is for use only on Linux, BSD, OS X, and similar systems |
that have a gnu or similar toolchain installed. The rmagick-win32 gem is a |
pre-compiled version of RMagick bundled with ImageMagick for use on |
Microsoft Windows systems. The rmagick-win32 gem is available on RubyForge.|
See http://rmagick.rubyforge.org/install-faq.html for more information. |

+----------------------------------------------------------------------------+
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

Provided configuration options:
        --with-opt-dir
        --without-opt-dir
        --with-opt-include
        --without-opt-include=${opt-dir}/include
        --with-opt-lib
        --without-opt-lib=${opt-dir}/lib
        --with-make-prog
        --srcdir=.
        --curdir
        --ruby=C:/Ruby/bin/ruby

Gem files will remain installed in
C:/Ruby/lib/ruby/gems/1.8/gems/rmagick-2.13.1
for inspection.
Results logged to
C:/Ruby/lib/ruby/gems/1.8/gems/rmagick-2.13.1/ext/RMagick/gem_
make.out

C:\Users\Pierre>

--
Posted via http://www.ruby-forum.com/.

hi there -

  judging by the C:, you're using a windows system... following the
link in the error you received led me here:
http://rubyforge.org/projects/rmagick/
  looks like this is the place to download the rmagick gem and installer
for windows...

  good luck-

  j

···

--
Posted via http://www.ruby-forum.com/.

Please see RubyInstaller wiki section, Tutorials:

To install RMagick gem you need RMagick development headers and
libraries, which you need to install from ImageMagick installers.

···

On Mar 9, 4:45 pm, Pierre Pepe <paniaguag...@gmail.com> wrote:

Running Win7 64 bit

Having troubles installing RMagick. I was following the read me, and I
only got to the part where it tells you to type out "gem install rmagick
--local" and then I get the following error: "ERROR: Could not find a
valid gem 'rmagick' (>= 0) in any repository"

So... basically I'm not sure how to continue from here? I keep reading
that there are ruby header files that I may not have or if I really need
them.

If I do, I'm not sure where or how to get them.

Sorry for my nubness ;_;

I appreciate the help in advance, thanks!

--
Luis Lavena

Pierre Pepe wrote in post #986560:

Running Win7 64 bit

Having troubles installing RMagick. I was following the read me, and I
only got to the part where it tells you to type out "gem install rmagick
--local" and then I get the following error: "ERROR: Could not find a
valid gem 'rmagick' (>= 0) in any repository"

So... basically I'm not sure how to continue from here? I keep reading
that there are ruby header files that I may not have or if I really need
them.

If I do, I'm not sure where or how to get them.

Sorry for my nubness ;_;

I appreciate the help in advance, thanks!

I ran into this error as well while trying to install rmagick on Windows
(32 bit XP). I needed to first navigate to the folder containing the
.gem file and then run chdir in order to set the folder as my current
directory, after that gem install rmagick --local works properly

C:\>chdir C:\Temp\rmagick-win32

C:\Temp\rmagick-win32>dir
Volume in drive C has no label.
Volume Serial Number is 0881-E678

Directory of C:\Temp\rmagick-win32

05/24/2012 11:52 AM <DIR> .
05/24/2012 11:52 AM <DIR> ..
10/04/2009 10:50 AM 12,792,388
ImageMagick-6.5.6-8-Q8-windows-dll.exe
10/04/2009 01:50 PM 7,344 README.html
10/04/2009 01:47 PM 11,233,280 rmagick-2.12.0-x86-mswin32.gem
10/04/2009 09:21 AM 1,269,635 RMagick-2.12.0.tar.gz
               4 File(s) 25,302,647 bytes
               2 Dir(s) 27,060,756,480 bytes free

C:\Temp\rmagick-win32> gem install rmagick --local

···

--
Posted via http://www.ruby-forum.com/.

J. K. wrote in post #986614:

hi there -

  judging by the C:, you're using a windows system... following the
link in the error you received (
http://rmagick.rubyforge.org/install-faq.html )led me here:
http://rubyforge.org/projects/rmagick/
  looks like this is the place to download the rmagick gem and installer
for windows...

  good luck-

  j

I downloaded and installed that already.

···

--
Posted via http://www.ruby-forum.com/.