[OT-OpenSource-Newbie] Building Ruby into VIM


(Steve Tuckner) #1

I have downloaded the latest sources for VIM 6.1 onto my Linux box and I
want to build Ruby support into VIM. I keep seeing that I should build
it with the +ruby option, but I don’t know where I do this. I tried to
do it when I doing the configure (eg. configure +ruby) but that doesn’t
do it. I tried #defining FEAT_RUBY in feature.h and rebuilding.

To test support I tried to do a colon then: ruby ‘print “hello”’ and I
get the message “E319: Sorry, the command is not available in this
version”.

Thanks for any help,

Steve Tuckner


(Ned Konz) #2

./configure --enable-rubyinterp

Look at the output from “configure --help”

···

On Tuesday 02 July 2002 06:50 am, Steve Tuckner wrote:

I have downloaded the latest sources for VIM 6.1 onto my Linux box
and I want to build Ruby support into VIM. I keep seeing that I
should build it with the +ruby option, but I don’t know where I do
this. I tried to do it when I doing the configure (eg. configure
+ruby) but that doesn’t do it. I tried #defining FEAT_RUBY in
feature.h and rebuilding.


Ned Konz
http://bike-nomad.com
GPG key ID: BEEA7EFE


(Steve Tuckner) #3

Ok that worked great. But (even more off-topic), this builds the executable
vim. I want to build gvim. I tried
configure --enable-rubyinterp --enable-gui and vim still is the regular vim
and there is not gvim executable. Sorry for more dumb questions :frowning:

Steve Tuckner

···

-----Original Message-----
From: Ned Konz [mailto:ned@bike-nomad.com]
Sent: Tuesday, July 02, 2002 9:06 AM
To: ruby-talk@ruby-lang.org
Subject: Re: [OT-OpenSource-Newbie] Building Ruby into VIM

On Tuesday 02 July 2002 06:50 am, Steve Tuckner wrote:

I have downloaded the latest sources for VIM 6.1 onto my Linux box
and I want to build Ruby support into VIM. I keep seeing that I
should build it with the +ruby option, but I don’t know where I do
this. I tried to do it when I doing the configure (eg. configure
+ruby) but that doesn’t do it. I tried #defining FEAT_RUBY in
feature.h and rebuilding.

./configure --enable-rubyinterp

Look at the output from “configure --help”

Ned Konz
http://bike-nomad.com
GPG key ID: BEEA7EFE


(James) #4

From: Steve Tuckner [mailto:STUCKNER@MULTITECH.COM]
Sent: Tuesday, July 02, 2002 7:47 AM
To: ruby-talk ML
Subject: RE: [OT-OpenSource-Newbie] Building Ruby into VIM

Ok that worked great. But (even more off-topic), this builds the
executable
vim. I want to build gvim. I tried
configure --enable-rubyinterp --enable-gui and vim still is the
regular vim
and there is not gvim executable. Sorry for more dumb questions :frowning:

Have you tried running
vim -g

It should launch the graphical version

James

···

-----Original Message-----

Steve Tuckner


(Ned Konz) #5

What that means, probably, is that configure couldn’t find the header
files it needs to build a GUI.

If you look at your auto/config.cache, what does it say for the line
that starts

ac_cv_have_x

Mine is:

ac_cv_have_x=${ac_cv_have_x=‘have_x=yes
ac_x_includes=/usr/X11R6/include ac_x_libraries=/usr/X11R6/lib’}

This is a dumb question, but do you have the XFree86-devel RPM
installed (assuming you’re running RedHat; other distros may have
different names for the package)? You should have a bunch of files in
/usr/include/X11 or somewhere similar.

Plus, if you want the Gtk and/or Gnome UIs to be built, you have to
have the respective -devel RPMs installed as well:

gtk±devel
gnome-core-devel (I think)

···

On Tuesday 02 July 2002 07:46 am, Steve Tuckner wrote:

Ok that worked great. But (even more off-topic), this builds the
executable vim. I want to build gvim. I tried
configure --enable-rubyinterp --enable-gui and vim still is the
regular vim and there is not gvim executable. Sorry for more dumb
questions :frowning:


Ned Konz
http://bike-nomad.com
GPG key ID: BEEA7EFE


(Michael Brailsford) #6

Ok that worked great. But (even more off-topic), this builds the executable
vim. I want to build gvim. I tried
configure --enable-rubyinterp --enable-gui and vim still is the regular vim
and there is not gvim executable. Sorry for more dumb questions :frowning:

Did you run “make install” as root? I have built vim many times and I
have never had any problem running “gvim” as opposed to vim. Running
make install should also install “evim”, “vimdiff”, “view”, “rview”,
“vimtutor” and a few others in /usr/bin. Note that all of those are
just links to the vim executable.

-Michael


(Steve Tuckner) #7

Thanks that worked fine.

···

-----Original Message-----
From: james@rubyxml.com [mailto:james@rubyxml.com]
Sent: Tuesday, July 02, 2002 10:14 AM
To: ruby-talk@ruby-lang.org
Subject: RE: [OT-OpenSource-Newbie] Building Ruby into VIM

-----Original Message-----
From: Steve Tuckner [mailto:STUCKNER@MULTITECH.COM]
Sent: Tuesday, July 02, 2002 7:47 AM
To: ruby-talk ML
Subject: RE: [OT-OpenSource-Newbie] Building Ruby into VIM

Ok that worked great. But (even more off-topic), this builds the
executable
vim. I want to build gvim. I tried
configure --enable-rubyinterp --enable-gui and vim still is the
regular vim
and there is not gvim executable. Sorry for more dumb questions :frowning:

Have you tried running
vim -g

It should launch the graphical version

James

Steve Tuckner


(Steve Tuckner) #8

vim -g was all I needed.

Thanks all for the help!!

···

-----Original Message-----
From: Ned Konz [mailto:ned@bike-nomad.com]
Sent: Tuesday, July 02, 2002 11:09 AM
To: ruby-talk@ruby-lang.org
Subject: Re: [OT-OpenSource-Newbie] Building Ruby into VIM

On Tuesday 02 July 2002 07:46 am, Steve Tuckner wrote:

Ok that worked great. But (even more off-topic), this builds the
executable vim. I want to build gvim. I tried
configure --enable-rubyinterp --enable-gui and vim still is the
regular vim and there is not gvim executable. Sorry for more dumb
questions :frowning:

What that means, probably, is that configure couldn’t find the header
files it needs to build a GUI.

If you look at your auto/config.cache, what does it say for the line
that starts

ac_cv_have_x

Mine is:

ac_cv_have_x=${ac_cv_have_x=‘have_x=yes
ac_x_includes=/usr/X11R6/include ac_x_libraries=/usr/X11R6/lib’}

This is a dumb question, but do you have the XFree86-devel RPM
installed (assuming you’re running RedHat; other distros may have
different names for the package)? You should have a bunch of files in
/usr/include/X11 or somewhere similar.

Plus, if you want the Gtk and/or Gnome UIs to be built, you have to
have the respective -devel RPMs installed as well:

gtk±devel
gnome-core-devel (I think)


Ned Konz
http://bike-nomad.com
GPG key ID: BEEA7EFE


(Tobi Reif) #9

brailsmt@yahoo.com wrote:

Did you run “make install” as root? I have built vim many times and I
have never had any problem running “gvim” as opposed to vim. Running
make install should also install “evim”, “vimdiff”, “view”, “rview”,
“vimtutor” and a few others in /usr/bin. Note that all of those are
just links to the vim executable.

… and must be on the system path to be callable without a path.
Perhaps that’s the issue here.

Tobi

···


http://www.pinkjuice.com/