"gem NAME, VERSION" && "require NAME" fails due to version conflict

Hi, I must be missing something very obvious but I don't get it. I
just want to use nokogiri 1.4.3:

~# gem list | grep nokogiri
nokogiri (1.4.4, 1.4.3)

~# irb

gem "nokogiri", "=1.4.3"

true

Nokogiri

NameError: uninitialized constant Object::Nokogiri

require "nokogiri"

Gem::LoadError: can't activate nokogiri (= 1.4.4, runtime) for ,
already activated nokogiri-1.4.3 for

How is supposed it to work? I know that "require_gem" is deprecated
(removed in fact).
I use gem 1.3.7.

Thanks a lot.

···

--
Iñaki Baz Castillo
<ibc@aliax.net>

Hi, I must be missing something very obvious but I don't get it. I
just want to use nokogiri 1.4.3:

~# gem list | grep nokogiri
nokogiri (1.4.4, 1.4.3)

~# irb
> gem "nokogiri", "=1.4.3"
true
> Nokogiri
NameError: uninitialized constant Object::Nokogiri
> require "nokogiri"
Gem::LoadError: can't activate nokogiri (= 1.4.4, runtime) for ,
already activated nokogiri-1.4.3 for

10002 % gem list nokogiri
nokogiri (1.4.4, 1.4.1)
10003 % irb

require "rubygems"

=> true

gem "nokogiri", "= 1.4.1"

=> true

require "nokogiri"

=> true

Nokogiri

=> Nokogiri
10004 % gem -v
1.5.3

···

On Feb 27, 2011, at 09:00 , Iñaki Baz Castillo wrote:

Same fails in my system with RubyGem 1.3.7. Note however that I'm
using the gem command provided by the Debian/Ubuntu package. I will
check upgrading to 1.5.3.

Thanks.

···

2011/2/28 Ryan Davis <ryand-ruby@zenspider.com>:

~# gem list | grep nokogiri
nokogiri (1.4.4, 1.4.3)

~# irb
> gem "nokogiri", "=1.4.3"
true
> Nokogiri
NameError: uninitialized constant Object::Nokogiri
> require "nokogiri"
Gem::LoadError: can't activate nokogiri (= 1.4.4, runtime) for ,
already activated nokogiri-1.4.3 for

10002 % gem list nokogiri
nokogiri (1.4.4, 1.4.1)
10003 % irb

require "rubygems"

=> true

gem "nokogiri", "= 1.4.1"

=> true

require "nokogiri"

=> true

Nokogiri

=> Nokogiri
10004 % gem -v
1.5.3

--
Iñaki Baz Castillo
<ibc@aliax.net>

Annoying, I get the very same error with Gem 1.5.3:

~# gem list nokogiri
nokogiri (1.4.4, 1.4.3)

irb(main):002:0> require "rubygems"
true

irb(main):003:0> gem "nokogiri", "=1.4.3"
true

irb(main):004:0> require "nokogiri"
Gem::LoadError: can't activate nokogiri (= 1.4.4, runtime) for ,
already activated nokogiri-1.4.3 for

~# gem -v
1.5.3

···

2011/2/28 Iñaki Baz Castillo <ibc@aliax.net>:

10002 % gem list nokogiri
nokogiri (1.4.4, 1.4.1)
10003 % irb

require "rubygems"

=> true

gem "nokogiri", "= 1.4.1"

=> true

require "nokogiri"

=> true

Nokogiri

=> Nokogiri
10004 % gem -v
1.5.3

Same fails in my system with RubyGem 1.3.7. Note however that I'm
using the gem command provided by the Debian/Ubuntu package. I will
check upgrading to 1.5.3.

--
Iñaki Baz Castillo
<ibc@aliax.net>