Exerb and socket

Has anyone out there tried creating a Windows executable with Exerb
a script that contains a “require ‘socket’” statement? I tried
contacting the author via email Friday in the early morning (Pacific
Daylight Time) but have had no response yet. Here’s the behavior I’m

proxy_Windows.rb:2: [BUG] Segmentation fault
ruby 1.6.8 (2002-12-24) [i586-mswin32]

abnormal program termination


where the proxy_Windows.rb script starts out

require 'smtpd’
require 'socket’
require ‘net/smtp’

and thus the executable is dying on requiring the socket library.

Which socket.so is included? This has happened to me for other c
extensions with exerb when then rbx contains a Ruby expecting a win32 or
mingw32 built extension and its gets a cygwin built one for example.
making sure its not that problem…


Robert Feldt

It’s the socket.so shipped with the PragProg installer, which I presume
is VC++ MSWin32. I don’t know what my Exerb cores were compiled with,
I’m using the ones I downloaded from the author’s site.



-----Original Message-----
From: Robert Feldt [mailto:feldt@ce.chalmers.se]
Sent: Monday, May 19, 2003 9:42 AM
To: ruby-talk ML
Subject: Re: Exerb and socket
On Tue, 20 May 2003, Albert Chou wrote: