Compiling problems on cygwin


(Shashank Date) #1

Rubyists,

I am trying to compile ruby-1.8.1 using cygwin and I get this error during
make:

make[1]: Entering directory /cygdrive/c/Documents and Settings/Shashank Date/cygwin/ruby-1.8.1/ext/bigdecimal' make[1]: *** No rule to make target/cygdrive/c/Documents’, needed by
bigdecimal.o'. Stop. make[1]: Leaving directory/cygdrive/c/Documents and Settings/Shashank
Date/cygwin/ruby-1.8.1/ext/bigdecimal’
make: *** [all] Error 1

Any suggestions?
– shanko


(Gavin Sinclair) #2

Looks like it’s the space in the path that’s doing it. Eliminate that
and try again.

FWIW I built the latest 1.8 from CVS on Cygwin very recently, no
problem.

Cheers,
Gavin

···

On Wednesday, February 18, 2004, 1:39:56 AM, Shashank wrote:

Rubyists,

I am trying to compile ruby-1.8.1 using cygwin and I get this error during
make:

make[1]: Entering directory /cygdrive/c/Documents and Settings/Shashank Date/cygwin/ruby-1.8.1/ext/bigdecimal' make[1]: *** No rule to make target/cygdrive/c/Documents’, needed by
bigdecimal.o'. Stop. make[1]: Leaving directory/cygdrive/c/Documents and Settings/Shashank
Date/cygwin/ruby-1.8.1/ext/bigdecimal’
make: *** [all] Error 1

Any suggestions?
– shanko


(Robert) #3

“Gavin Sinclair” gsinclair@soyabean.com.au schrieb im Newsbeitrag
news:231610495.20040218015054@soyabean.com.au

Rubyists,

I am trying to compile ruby-1.8.1 using cygwin and I get this error
during

make:

make[1]: Entering directory `/cygdrive/c/Documents and
Settings/Shashank

Date/cygwin/ruby-1.8.1/ext/bigdecimal’
make[1]: *** No rule to make target /cygdrive/c/Documents', needed bybigdecimal.o’. Stop.
make[1]: Leaving directory `/cygdrive/c/Documents and
Settings/Shashank

Date/cygwin/ruby-1.8.1/ext/bigdecimal’
make: *** [all] Error 1

Any suggestions?
– shanko

Looks like it’s the space in the path that’s doing it. Eliminate that
and try again.

IMHO rather the build system should be made space safe…

robert
···

On Wednesday, February 18, 2004, 1:39:56 AM, Shashank wrote:


(Shashank Date) #4

“Gavin Sinclair” gsinclair@soyabean.com.au wrote in message

Looks like it’s the space in the path that’s doing it. Eliminate that
and try again.

But of course ! Spotted that a few minutes after posting … sorry for the
noise.

– shanko