Bug in HTTPS.Post with headers via Proxy?

(Ralf Jonas) #1

Hi all,

I'm toying around with the eBay XML API - of course I tried in Ruby first.
But meanwhile I debugged the entire http.rb trying to make it work but still
failed.
So I wrote the very same simple app in Perl and it worked at once.

http.rb messes up the headers completely,
  it changes the order (no wonder, they're stored in a Hash)
  it changes the writing (first downcase everything, then separate by dash
'-' and capitalize)
  it adds some more header lines like 'accept: */*' and 'connection: close'.

But as a real Rubyist I want to have this app work in Ruby, not in Perl.
Of course I tried the SOAP API also, but wsdl2ruby is unable to handle the
new APIs from eBay, because wsdl2ruby doesn't understand "namespace" for
instance. Next I don't know how to apply the SecurityCredentials and last
but not least I do want to use XML.

It's not easy to debug whats going on via the line because the whole
connection is secured (https). And it has to be (says eBay).

So has anyone managed to get a working connection from Ruby to the eBay
API - either via XML or by using SOAP? Then please drop my a line, I don't
know, where to look else.

Thanks in advance
  Ralf Jonas