ANNOUNCE: FXRuby-1.0.11 Now Available


(Lyle Johnson) #1

I am pleased to announce the latest release of FXRuby, the Ruby language
bindings for the FOX GUI toolkit. FOX is a C+±based toolkit for developing
graphical user interfaces easily and effectively. It offers a wide, and
growing, collection of widgets, and provides state-of-the-art facilities
such as drag-and-drop, selection, as well as OpenGL widgets for 3-D
graphical manipulation. FOX also implements icons, images, and
user-convenience features such as status line help and tooltips.

Please see the comments on the home page concerning any problems with this
release, or the change log to see what has changed since the previous
release.

The FXRuby home page is here:

http://www.fxruby.org

and the source tarball can be downloaded here:

http://prdownloads.sourceforge.net/fxruby/FXRuby-1.0.11.tar.gz

A binary installer for Windows, compatible with the mswin32-based versions
of Ruby 1.6.x for Windows, is available for download here:

http://prdownloads.sourceforge.net/fxruby/FXRuby-1.0.11-win32.exe

and a Linux RPM (for Ruby 1.6) is available for download here:

http://prdownloads.sourceforge.net/fxruby/FXRuby-1.0.11-1.i386.rpm

Note that this release of FXRuby depends on FOX version 1.0.0 (or later),
which
can be downloaded from the FOX downloads page here:

http://www.fox-toolkit.org/download.html

Please feel free to send me any questions or comments, and watch this space
for future announcements!

Lyle


(Joel VanderWerf) #2

Lyle Johnson wrote:

http://prdownloads.sourceforge.net/fxruby/FXRuby-1.0.11.tar.gz

Lyle, this file seems to be corrupted, and too small (9179 bytes). The
rpm seems to have similar problems.


(Ian Macdonald) #3

It’s on a redirect, so things like wget go wrong. Use Lynx instead.

Ian

···

On Fri 21 Jun 2002 at 02:58:27 +0900, Joel VanderWerf wrote:

Lyle Johnson wrote:

http://prdownloads.sourceforge.net/fxruby/FXRuby-1.0.11.tar.gz

Lyle, this file seems to be corrupted, and too small (9179 bytes). The
rpm seems to have similar problems.


Ian Macdonald | It is impossible for an optimist to be
ian@caliban.org | pleasantly surprised.
>
>
>


(Joel VanderWerf) #4

Ian Macdonald wrote:

Lyle Johnson wrote:

http://prdownloads.sourceforge.net/fxruby/FXRuby-1.0.11.tar.gz

Lyle, this file seems to be corrupted, and too small (9179 bytes). The
rpm seems to have similar problems.

It’s on a redirect, so things like wget go wrong. Use Lynx instead.

I guess so. I was using Konqueror (which has worked on sf mirrors
before). Lynx seems to have worked. Thanks.

···

On Fri 21 Jun 2002 at 02:58:27 +0900, Joel VanderWerf wrote: