ActiveRecord

I'm learning to use activerecord (not rails).

Two gems are necessary for this: the activerecord gem and the mysql
adpater (I'm using MySQL). I installed both gems (I think successfully).

When I inspect the directory where all my local gems are installed, I
get this:

~/.rvm/gems/ruby-1.9.2-p290/gems marcc$ ls
total 0
drwxr-xr-x 28 marcc staff 952B Aug 15 19:47 .
drwxr-xr-x 7 marcc staff 238B Jul 25 11:58 ..
drwxr-xr-x 8 marcc staff 272B Jul 25 12:07 abstract-1.0.0
drwxr-xr-x 6 marcc staff 204B Jul 25 12:07 actionmailer-3.0.9
drwxr-xr-x 6 marcc staff 204B Jul 25 12:07 actionpack-3.0.9
drwxr-xr-x 6 marcc staff 204B Jul 25 12:07 activemodel-3.0.9
drwxr-xr-x 6 marcc staff 204B Jul 25 12:07 activerecord-3.0.9
drwxr-xr-x 6 marcc staff 204B Jul 25 12:07 activeresource-3.0.9
drwxr-xr-x 5 marcc staff 170B Jul 25 12:07 activesupport-3.0.9
drwxr-xr-x 12 marcc staff 408B Jul 25 12:07 arel-2.0.10
drwxr-xr-x 9 marcc staff 306B Jul 25 12:07 builder-2.1.2
drwxr-xr-x 14 marcc staff 476B Jul 25 12:08 bundler-1.0.15
drwxr-xr-x 14 marcc staff 476B Jul 25 12:07 erubis-2.6.6
drwxr-xr-x 8 marcc staff 272B Jul 25 12:07 i18n-0.5.0
drwxr-xr-x 7 marcc staff 238B Jul 25 12:07 mail-2.2.19
drwxr-xr-x 12 marcc staff 408B Jul 25 12:07 mime-types-1.16
drwxr-xr-x 13 marcc staff 442B Aug 15 19:47 mysql-2.8.1
drwxr-xr-x 9 marcc staff 306B Jul 25 12:07 polyglot-0.3.1
drwxr-xr-x 13 marcc staff 442B Jul 25 12:07 rack-1.2.3
drwxr-xr-x 5 marcc staff 170B Jul 25 12:07 rack-mount-0.6.14
drwxr-xr-x 14 marcc staff 476B Jul 25 12:07 rack-test-0.5.7
drwxr-xr-x 3 marcc staff 102B Jul 25 12:08 rails-3.0.9
drwxr-xr-x 6 marcc staff 204B Jul 25 12:08 railties-3.0.9
drwxr-xr-x 12 marcc staff 408B Jul 25 11:58 rake-0.8.7
drwxr-xr-x 14 marcc staff 476B Jul 25 12:08 rdoc-3.8
drwxr-xr-x 9 marcc staff 306B Jul 25 12:07 thor-0.14.6
drwxr-xr-x 11 marcc staff 374B Jul 25 12:07 treetop-1.4.9
drwxr-xr-x 8 marcc staff 272B Jul 25 12:07 tzinfo-0.3.29

When I run the gem list command, I get this:

~ marcc$ gem list

*** LOCAL GEMS ***

abstract (1.0.0)
actionmailer (3.0.9)
actionpack (3.0.9)
activemodel (3.0.9)
activerecord (3.0.9)
activeresource (3.0.9)
activesupport (3.0.9)
arel (2.0.10)
builder (2.1.2)
bundler (1.0.15)
erubis (2.6.6)
i18n (0.5.0)
mail (2.2.19)
mime-types (1.16)
polyglot (0.3.1)
rack (1.2.3)
rack-mount (0.6.14)
rack-test (0.5.7)
rails (3.0.9)
railties (3.0.9)
rake (0.8.7)
rdoc (3.8)
thor (0.14.6)
treetop (1.4.9)
tzinfo (0.3.29)

As you can see, the mysql-2.8.1 gem directory is there but the mysql gem
is not listed when I do gem list.

Why is that?

···

--
Posted via http://www.ruby-forum.com/.

I'd guess that your MySQL gem did *not* install successfully.

What's in that directory? Hint: look for an installation log file...

···

On Tue, Aug 16, 2011 at 1:31 PM, Marc Chanliau <marc.chanliau@gmail.com> wrote:

Two gems are necessary for this: the activerecord gem and the mysql
adpater (I'm using MySQL). I installed both gems (I think successfully).

As you can see, the mysql-2.8.1 gem directory is there but the mysql gem
is not listed when I do gem list.

Why is that?

--
Hassan Schroeder ------------------------ hassan.schroeder@gmail.com
http://about.me/hassanschroeder
twitter: @hassan