Sequel (load error) - used in production PC

I've got my development PC and all programs work.

Now I've copied the directories across to another PC (both running
Kubuntu 10.04)

Can't get the dam production code to work on new PC!!!
Know it's all down to paths etc - any help?

using fxruby.

would like my code to be in a more secure place where users cannot read
the files but only execute them.

but 1st thing 1st.

the error I get with code in my home directory with user & group access
set to my login username.

/sequel1.rb:1:in `require': no such file to load -- sequel (LoadError)
        from ./sequel1.rb:1
        from guifront.rb:5:in `require'
        from guifront.rb:5

another error i get is to do with il8n (this occurs when i use require
'rubygems' in my program so I'm not sure how important this is.

2nd thing is how can I run the same code from

The above is to my understanding where you'd put files that you want to
be made accessible on a global scale (not limited to a particular user.

I want to set the rights so that the programs run but the users cannot
access into the directory and I will other directories in under 1.8

these users will not have group rights to anything other than users.

users will not be connected to any other group (people logging in are
restricted to their home directory and maybe able to browse but not to
alter things else where in the filesystem).

this is the first time I've tried to port my code to a PC that's be
freshly setup.

I.E. I've installed ruby 1.8.7,
     load required gems via sudo gem install <gem wanted> etc
     from the /var/local/lib/site_ruby/1.8/mycode tried to run the
programs and
     got errors referred to in [1] then copied the programs to my home
     with not much better results.

I've just been told the code & PC is wanted this Monday.

I've been looking for guidance on the web but not found anything or my
google foo hasn't lead me to anything that has solved my problem.

anyone able to help?



Posted via