Segfaults from the 'object-free' dtrace probe

Hi All-

Has anyone had any luck with the 'object-free' dtrace probe... ever... on
any platform? It segfaults ruby without fail, absolutely 100% of the time,
everywhere.

It did it in Leopard, and there's a thread about it here:
http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-talk/287796 .

I tried testing it again yesterday in Snow Leopard and got the same
segfault. Then in OpenSolaris 2009.06, and then OpenSolaris b133 that came
out last night. Without fail they all die after the probe fires.

There was a patch mentioned in the thread above, did that ever come about?

-Dane

Ahhh... I think I see what it's doing, at least in a simple test case
I just cooked up that doesn't segfault, but rather explodes with:
[BUG] object allocation during garbage collection phase

The object-free probe fires during GC in obj_free. The entire probe is
two lines, most of which is dtrace boilerplate.. So the only thing
that could be causing it is:
    rb_class2name(CLASS_OF(obj)));

So... that ends up creating an object in there I assume, right?

-Dane

···

On Sat, Feb 20, 2010 at 4:23 PM, Dane Jensen <dane.jensen@gmail.com> wrote:

Hi All-

Has anyone had any luck with the 'object-free' dtrace probe... ever... on
any platform? It segfaults ruby without fail, absolutely 100% of the time,
everywhere.

It did it in Leopard, and there's a thread about it here:
http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-talk/287796 .

I tried testing it again yesterday in Snow Leopard and got the same
segfault. Then in OpenSolaris 2009.06, and then OpenSolaris b133 that came
out last night. Without fail they all die after the probe fires.

There was a patch mentioned in the thread above, did that ever come about?

-Dane