[ruby-talk:444401] [ANN] wxRuby3 0.9.5 release

This release fixes a very annoying restriction for doxygen and improves and extends
Wx::ComboCtrl support.

wxRuby3 is a cross-platform GUI library for Ruby, based on the mature wxWidgets GUI
toolkit for C++. It uses native widgets wherever possible, providing the correct look,
feel and behavior to GUI applications on Windows, OS X and Linux/GTK. wxRuby aims to
provide a comprehensive solution to developing professional-standard desktop
applications in Ruby.
wxRuby3 also provides extensive and complete reference documentation.

What's changed in this release:

- the (very annoying) restriction on more recent doxygen versions has been
  removed (thanks go to the wxPython Phoenix team for working this out); it
  is now possible to build using the most recent versions of doxygen (this
  should make it possible to build on any recent Linux distribution without
  problems)
- improve and extend support for Wx::ComboCtrl and user defined popup controls
  and update documentation
- add regression tests

If you are interested check this out:

Documentation: File: README — wxRuby3 API Documentation

Github: GitHub - mcorino/wxRuby3: Ruby Cross-Platform GUI extension

Rubygems: wxruby3 | RubyGems.org | your community gem host

···

______________________________________________
ruby-talk mailing list -- ruby-talk@ml.ruby-lang.org
To unsubscribe send an email to ruby-talk-leave@ml.ruby-lang.org
ruby-talk info -- Info | ruby-talk@ml.ruby-lang.org - ml.ruby-lang.org