Rbconfig.rb problems

Hi! I just reading the excellent Programming Ruby II book, and
it says I should be able to do this:

···

=======================================
C:\src\fltk-1.1.5rc3>irb
irb(main):001:0> require 'rbconfig.rb'
=> false
irb(main):002:0> puts $:
c:/ruby/lib/ruby/site_ruby/1.8
c:/ruby/lib/ruby/site_ruby/1.8/i386-msvcrt
c:/ruby/lib/ruby/site_ruby
c:/ruby/lib/ruby/1.8
c:/ruby/lib/ruby/1.8/i386-mswin32
..
=> nil
irb(main):003:0> exit

C:\src\fltk-1.1.5rc3>ruby -v
ruby 1.8.2 (2004-06-29) [i386-mswin32]
C:\ruby\lib\ruby\1.8\i386-mswin32>dir *.rb
  Volume in drive C has no label.
  Volume Serial Number is 9008-FDFE

  Directory of C:\ruby\lib\ruby\1.8\i386-mswin32

06/30/2004 09:42 AM 5,407 rbconfig.rb

(This installation was a pre-compiled binary distribution.)
Any ideas why this doesn't work? Thanks!
-- Glenn

Glenn M. Lewis ha scritto:

Hi! I just reading the excellent Programming Ruby II book, and
it says I should be able to do this:

my windows ruby version is
ruby 1.8.2 (2004-07-29) [i386-mswin32]

and I have it. I guess something is messed up in your installation.
Anyway you may like to upgrade to the latest installer.
hope this helps..

: Any ideas why this doesn't work? Thanks!

"This doesn't work" is not a good error description. If you mean why
did require return false, it is because irb had already required it.

Paul

···

On Fri, Oct 08, 2004 at 06:39:45AM +0900, Glenn M. Lewis wrote:

irb(main):001:0> require 'rbconfig.rb'
=> false
(This installation was a pre-compiled binary distribution.)