Mandrake 8.2 and FXRuby build issue

I am trying to install FXRuby/Fox/FXScintilla on a new Mandrake 8.2
system.
I built Ruby 1.7.2 from the CVS tree.

I then installed…

libfox0-1.0.11-3mdk.i586.rpm
libfox0-devel-1.0.11-3mdk.i586.rpm

…just for sanity’s sake I installed:

fox-example-apps-1.0.11-3mdk.i586.rpm

and ran the calculator example…so fox is installed right.

I also installed:

fxscintilla-1.46.2-1.i586.rpm
fxscintilla-devel-1.46.2-1.i586.rpm

And then built FXRuby with FXScintilla support. That build process
worked just dandy…and it installed:

/usr/local/lib/ruby/site_ruby/1.7/i686-linux/fox.so

as well as the .rb files…everything appears to be in place.

Here is the problem:

irb(main):001:0> require 'fox’
LoadError: /usr/lib/libcrypto.so.0: shared object not open -
/usr/local/lib/ruby/site_ruby/1.7/i686-linux/fox.so
from (irb):1:in 'require’
from (irb):1

I also performed an ldd on fox.so, and checked to make sure all those
files were present…and they are (also checked libcrypto.so.0).

-rich

···

-----Original Message-----
From: freeride-devel-admin@mail.freesoftware.fsf.org [mailto:freeride-
devel-admin@mail.freesoftware.fsf.org] On Behalf Of Laurent Julliard
Sent: Tuesday, July 09, 2002 9:16 AM
To: freeride-devel@mail.freesoftware.fsf.org
Subject: Re: [FR-devel] Mandrake issue.

Rich Kilmer wrote:

The RPMs you listed are the exact ones installed…so

libcrypto.so.0 -> libcrypto.so.0.9.6

Should I post this to the main Ruby list and have Lyle chime in?

-Rich

Are you still using FOX 1.1.x or have you downgraded to 1.0.x ?

LJ


Laurent JULLIARD - Xerox R&T/SSTC/XPA - Open Source team

Host your Xerox Software project on CodeX: http://codex.xerox.com
Linux@Xerox community: http://xww.linux.world.xerox.com


Freeride-devel mailing list
Freeride-devel@mail.freesoftware.fsf.org
http://mail.freesoftware.fsf.org/mailman/listinfo/freeride-devel


Freeride-devel mailing list
Freeride-devel@mail.freesoftware.fsf.org
http://mail.freesoftware.fsf.org/mailman/listinfo/freeride-devel

“Rich Kilmer” rich@infoether.com wrote in message
news:002a01c2276c$aa9a8600$d701a8c0@TECHNO…

Here is the problem:

irb(main):001:0> require 'fox’
LoadError: /usr/lib/libcrypto.so.0: shared object not open -
/usr/local/lib/ruby/site_ruby/1.7/i686-linux/fox.so
from (irb):1:in 'require’
from (irb):1

Let me be the first to chime in and say, “I don’t know what’s wrong” :wink:

I wonder what the error message “shared object not open” even means. When I
google’d for this I found a couple of other postings (on a PHP site)
mentioning this error but offering no solution.

I’ve been getting a similar message ever since I re-installed Mandrake
8.2 after my hard disk got toasted. I just now ran it down to the setting
of my LD_LIBRARY_PATH environment variable. Before, I simply set it to
/usr/local/lib, but I’ve determined that it actually must include
/usr/lib as well. That is:

export LD_LIBRARY_PATH=/usr/lib:/usr/local/lib

I had previously interpreted ld.so(8) to say that ld.so would always
search /usr/lib, but I now assume that the LD_LIBRARY_PATH must include
ALL the directories to be searched, not just the libraries in addition
to /usr/lib.

Since I don’t remember having this problem before, I’m inclined to
believe that something changed in 8.2 recently. Perhaps a
Linux guru will explain…

HTH!

(snip)

···

On Tue, 09 Jul 2002 13:27:20 -0400, Rich Kilmer wrote:

Here is the problem:

irb(main):001:0> require 'fox’
LoadError: /usr/lib/libcrypto.so.0: shared object not open -
/usr/local/lib/ruby/site_ruby/1.7/i686-linux/fox.so
from (irb):1:in 'require’
from (irb):1

I also performed an ldd on fox.so, and checked to make sure all those
files were present…and they are (also checked libcrypto.so.0).

-rich

Hi Tim!
In article pan.2002.07.11.17.30.22.916805.6974@nc.rr.com,
Tim Hunter cyclists@nc.rr.com writes:

I had previously interpreted ld.so(8) to say that ld.so would always
search /usr/lib, but I now assume that the LD_LIBRARY_PATH must include
ALL the directories to be searched, not just the libraries in addition
to /usr/lib.

IMHO /usr/lib should not have to be in LD_LIBRARY_PATH at all.
I have only a SuSE system but i would sugest having a look into
/etc/ld.so.conf and see whether the entries look reasonable.

Then try the command ‘ldconfig -v’ as root.

My SuSE /etc/ld.so.conf looks like this:
/lib-aout
/usr/X11R6/lib/Xaw95
/usr/X11R6/lib/Xaw3d
/usr/X11R6/lib
/usr/i486-linux/lib
/usr/i486-linux-libc5/lib=libc5
/usr/i486-linux-libc6/lib=libc6
/usr/i486-linuxaout/lib
/usr/i386-suse-linux/lib
/usr/local/lib
/usr/openwin/lib
/opt/kde/lib
/opt/kde2/lib
/opt/gnome/lib

/usr/lib should be searched by default and LD_LIBRARY_PATH should only
be used for special needs.

Hope that helps,
Martin.

···


The early bird catches the worm. If you want something else for
breakfast, get up later.