Getting LoadError when using ruby and gem

I m seeing below error when I m trying to run one of the application.

[ppok@xx23 HH]$ uname -a
Linux xx23.iky.knobb 2.6.18-92.el5 #1 SMP Tue Apr 29 13:16:12 EDT 2008
i686 i686 i386 GNU/Linux

[ppok@xx23 HH]]$ ruby --version;gem --version
ruby 1.8.5 (2006-08-25) [i386-linux]
1.3.1

/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require': no such file to load -- text/format (LoadError)
        from
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
        from ./commandline/application.rb:171:in `man'
        from ./commandline/application.rb:370:in `__help'
        from ./commandline/optionparser/optionparser.rb:242:in `call'
        from ./commandline/optionparser/optionparser.rb:242:in `parse'
        from ./commandline/optionparser/optionparser.rb:447:in `call'
        from ./commandline/optionparser/optionparser.rb:447:in
`parse_argv'
        from ./commandline/optionparser/optionparser.rb:447:in `each'
        from ./commandline/optionparser/optionparser.rb:447:in
`parse_argv'
        from ./commandline/optionparser/optionparser.rb:227:in `parse'
        from ./commandline/application.rb:307:in `__parse_command_line'
        from ./commandline/application.rb:250:in `run'
        from ./commandline/application.rb:270:in `__set_auto_run'
        from ./hh_main.rb:39

I understood from the error that one of the libraries (text/format) are
missing from the binary. Can anybody please help me in getting the
required libraries.

Best Regards,
Bala

···

--
Posted via http://www.ruby-forum.com/.

Hi, Bela

Try this
  gem list text-format

if nothing found, use
  gem install text-format

- Alex

···

--
Posted via http://www.ruby-forum.com/.