Fast Debugger (Ruby 1.9.2, DevKit 4.5.0, JDK 6u22, NetBeans 6.9.1)

I've been trying to run this configuration in debug mode on my Windows
Vista x86 machine for a few days now with no luck. I do not have Visual
Studio installed. Everytime I try to debug, NetBeans prompts me to
install the Fast Debugger. And if I don't I get translation errors
around the "thread" class. I know that nstalling the Fast Debugger will
make everything work because I have successfully installed and debugged
on my other machine was has Visual Studio installed. I have the
following files

linecache-0.43-mswin32.gem
ruby-debug-base-0.10.3-mswin32.gem

which I can successfully install. But installing "ruby-debug" always
fails and I have tried to "gem install" it with all kinds of switches as
recommended by the many of blogs I've seen on-line but I always get the
same errors...

···

=========================================================================
Temporarily enhancing PATH to include DevKit...
Building native extensions. This could take a while...
ERROR: Error installing ruby-debug-ide:
  ERROR: Failed to build gem native extension.

C:/Ruby192/bin/ruby.exe mkrf_conf.rb
Building native extensions. This could take a while...

Gem files will remain installed in
C:/Ruby192/lib/ruby/gems/1.9.1/gems/ruby-debug-ide-0.4.9 for inspection.
Results logged to
C:/Ruby192/lib/ruby/gems/1.9.1/gems/ruby-debug-ide-0.4.9/ext/gem_make.out

Can someone tell me definitively how to get this guy installed? Or can
somebody instruct me if and how I can move the built native gems from my
Visual Studio dev machine to the non-dev machine?

Much obliged.

--
Posted via http://www.ruby-forum.com/.

Allan Chin wrote in post #961043:

I've been trying to run this configuration in debug mode on my Windows
Vista x86 machine for a few days now with no luck. I do not have Visual
Studio installed. Everytime I try to debug, NetBeans prompts me to
install the Fast Debugger. And if I don't I get translation errors
around the "thread" class. I know that nstalling the Fast Debugger will
make everything work because I have successfully installed and debugged
on my other machine was has Visual Studio installed. I have the
following files

linecache-0.43-mswin32.gem
ruby-debug-base-0.10.3-mswin32.gem

These are probably for mswin32 release--you are using mingw I think, so
it may not be compatible.

which I can successfully install. But installing "ruby-debug" always
fails and I have tried to "gem install" it with all kinds of switches as
recommended by the many of blogs I've seen on-line but I always get the
same errors...

=========================================================================
Temporarily enhancing PATH to include DevKit...
Building native extensions. This could take a while...
ERROR: Error installing ruby-debug-ide:
  ERROR: Failed to build gem native extension.

C:/Ruby192/bin/ruby.exe mkrf_conf.rb
Building native extensions. This could take a while...

Gem files will remain installed in
C:/Ruby192/lib/ruby/gems/1.9.1/gems/ruby-debug-ide-0.4.9 for inspection.
Results logged to
C:/Ruby192/lib/ruby/gems/1.9.1/gems/ruby-debug-ide-0.4.9/ext/gem_make.out

Can someone tell me definitively how to get this guy installed? Or can
somebody instruct me if and how I can move the built native gems from my
Visual Studio dev machine to the non-dev machine?

What are the contents of gem_make.out and mkmf.log?
maybe try installing ruby-debug19 from the command line?

···

--
Posted via http://www.ruby-forum.com/\.

If your Ruby compiled with Visual Studio?

Unless you compiled yourself, I guess not (also it seems RubyInstaller
+ DevKit)

A suggestion?

1. Download RubyInstaller Downloads

2. Install it in the recommended directory

3. Download DevKit Downloads

4. Extract it to a folder (C:\RubyDevKit for example)

5. Open a command prompt and follow the DevKit installation
instructions: Development Kit · oneclick/rubyinstaller Wiki · GitHub

6. gem install ruby-debug (for ruby 1.8) or ruby-debug19 (for Ruby
1.9.x)

Please note that ruby-debug needs to download Ruby source package to
compile it extension. That is because it depends on some Ruby
internals not exposed otherwise.

Due this, it requires an active internet connection.

···

On Nov 12, 2:56 pm, Allan Chin <achin5...@hotmail.com> wrote:

I've been trying to run this configuration in debug mode on my Windows
Vista x86 machine for a few days now with no luck. I do not have Visual
Studio installed. Everytime I try to debug, NetBeans prompts me to
install the Fast Debugger. And if I don't I get translation errors
around the "thread" class. I know that nstalling the Fast Debugger will
make everything work because I have successfully installed and debugged
on my other machine was has Visual Studio installed. I have the
following files

=========================================================================
Temporarily enhancing PATH to include DevKit...
Building native extensions. This could take a while...
ERROR: Error installing ruby-debug-ide:
ERROR: Failed to build gem native extension.

C:/Ruby192/bin/ruby.exe mkrf_conf.rb
Building native extensions. This could take a while...

Gem files will remain installed in
C:/Ruby192/lib/ruby/gems/1.9.1/gems/ruby-debug-ide-0.4.9 for inspection.
Results logged to
C:/Ruby192/lib/ruby/gems/1.9.1/gems/ruby-debug-ide-0.4.9/ext/gem_make.out

Can someone tell me definitively how to get this guy installed? Or can
somebody instruct me if and how I can move the built native gems from my
Visual Studio dev machine to the non-dev machine?

--
Luis Lavena

Ok, I followed Luis' instructions although I unzipped the DevKit right
over the Ruby192 install folder. I did NOT gem install these.

linecache-0.43-mswin32.gem
ruby-debug-base-0.10.3-mswin32.gem

The dev machine which has Visual Studio and the Ruby Fast Debugger has
these gems:

ruby-debug-base19-0.11.24
ruby-debug-ide-0.4.9

So I attempted a gem install of ruby-debug19. I attached the
gem-make.out and the mkmf.log files to this reply. And here is my
output.

···

=======================================================================
C:\Ruby192>gem install ruby-debug19 -p http://web-proxy:8080
Temporarily enhancing PATH to include DevKit...
Building native extensions. This could take a while...
ERROR: Error installing ruby-debug19:
        ERROR: Failed to build gem native extension.

C:/Ruby192/bin/ruby.exe extconf.rb
checking for vm_core.h... *** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

Provided configuration options:
        --with-opt-dir
        --without-opt-dir
        --with-opt-include
        --without-opt-include=${opt-dir}/include
        --with-opt-lib
        --without-opt-lib=${opt-dir}/lib
        --with-make-prog
        --without-make-prog
        --srcdir=.
        --curdir
        --ruby=C:/Ruby192/bin/ruby
        --with-ruby-dir
        --without-ruby-dir
        --with-ruby-include
        --without-ruby-include=${ruby-dir}/include
        --with-ruby-lib
        --without-ruby-lib=${ruby-dir}/lib
C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:368:in `try_do': The complier failed
to genera
te an executable file. (RuntimeError)
You have to install development tools first.
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:452:in `try_cpp'
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:834:in `block in
have_header'
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:693:in `block in
checking_for'
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:280:in `block (2 levels)
in postp
one'
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:254:in `open'
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:280:in `block in
postpone'
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:254:in `open'
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:276:in `postpone'
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:692:in `checking_for'
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:833:in `have_header'
        from extconf.rb:15:in `block in <main>'
        from
C:/Ruby192/lib/ruby/gems/1.9.1/gems/ruby_core_source-0.1.4/lib/ruby
_core_source.rb:18:in `call'
        from
C:/Ruby192/lib/ruby/gems/1.9.1/gems/ruby_core_source-0.1.4/lib/ruby
_core_source.rb:18:in `create_makefile_with_core'
        from extconf.rb:20:in `<main>'

Gem files will remain installed in
C:/Ruby192/lib/ruby/gems/1.9.1/gems/linecache
19-0.5.11 for inspection.
Results logged to
C:/Ruby192/lib/ruby/gems/1.9.1/gems/linecache19-0.5.11/ext/tra
ce_nums/gem_make.out

C:\Ruby192>

Thanks guys.

Attachments:
http://www.ruby-forum.com/attachment/5398/gem_make.out
http://www.ruby-forum.com/attachment/5399/mkmf.log

--
Posted via http://www.ruby-forum.com/.

I only copied the DevKit over the existing Ruby install because there
were a few blogs which mentioned to do that. But at any rate, I
installed the DevKit in a separate folder and installed it via the
"init" and "install" scripts. They worked ok, but the ruby-debug19 seems
to fail the same way.

···

==========================================================================

D:\Downloads\Ruby\DevKit>ruby dk.rb init
[INFO] found RubyInstaller v1.9.2 at C:/Ruby192

Initialization complete! Please review and modify the auto-generated
'config.yml' file to ensure it contains the root directories to all
of the installed Rubies you want enhanced by the DevKit.

D:\Downloads\Ruby\DevKit>ruby dk.rb install
[INFO] Installing
C:/Ruby192/lib/ruby/1.9.1/rubygems/defaults/operating_system.r
b
[INFO] Installing C:/Ruby192/lib/ruby/site_ruby/devkit.rb

D:\Downloads\Ruby\DevKit>gem install ruby-debug19 -p
http://web-proxy:8080
Temporarily enhancing PATH to include DevKit...
Building native extensions. This could take a while...
ERROR: Error installing ruby-debug19:
        ERROR: Failed to build gem native extension.

C:/Ruby192/bin/ruby.exe extconf.rb
checking for vm_core.h... *** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

Provided configuration options:
        --with-opt-dir
        --without-opt-dir
        --with-opt-include
        --without-opt-include=${opt-dir}/include
        --with-opt-lib
        --without-opt-lib=${opt-dir}/lib
        --with-make-prog
        --without-make-prog
        --srcdir=.
        --curdir
        --ruby=C:/Ruby192/bin/ruby
        --with-ruby-dir
        --without-ruby-dir
        --with-ruby-include
        --without-ruby-include=${ruby-dir}/include
        --with-ruby-lib
        --without-ruby-lib=${ruby-dir}/lib
C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:368:in `try_do': The complier failed
to genera
te an executable file. (RuntimeError)
You have to install development tools first.
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:452:in `try_cpp'
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:834:in `block in
have_header'
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:693:in `block in
checking_for'
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:280:in `block (2 levels)
in postp
one'
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:254:in `open'
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:280:in `block in
postpone'
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:254:in `open'
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:276:in `postpone'
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:692:in `checking_for'
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:833:in `have_header'
        from extconf.rb:15:in `block in <main>'
        from
C:/Ruby192/lib/ruby/gems/1.9.1/gems/ruby_core_source-0.1.4/lib/ruby
_core_source.rb:18:in `call'
        from
C:/Ruby192/lib/ruby/gems/1.9.1/gems/ruby_core_source-0.1.4/lib/ruby
_core_source.rb:18:in `create_makefile_with_core'
        from extconf.rb:20:in `<main>'

Gem files will remain installed in
C:/Ruby192/lib/ruby/gems/1.9.1/gems/linecache
19-0.5.11 for inspection.
Results logged to
C:/Ruby192/lib/ruby/gems/1.9.1/gems/linecache19-0.5.11/ext/tra
ce_nums/gem_make.out

D:\Downloads\Ruby\DevKit>

By the way, the "smoke test", gem install rdiscount --platform=Ruby -p
http://web-proxy:8080 fails the same way.

--
Posted via http://www.ruby-forum.com/.

I've had the same failure (1.9.2 only) at times, but never looked at it
close enough to know why...(that's with gcc on the path, so it's no lack
of dev tools...)

···

--
Posted via http://www.ruby-forum.com/.

-p http://web-proxy:8080 works fine when I install the uuid gem. And the
next time I run into a mis-informed article, I will provide the link.
But up to now there were many. Here's the output of the rdiscount debug
install.

···

=========================================================================
D:\Downloads\Ruby>gem install rdiscount --platform=ruby --http-proxy
http://web-
proxy:8080 --debug -V
Exception `NameError' at
C:/Ruby192/lib/ruby/1.9.1/rubygems/command_manager.rb:1
64 - uninitialized constant Gem::Commands::InstallCommand
Exception `NameError' at C:/Ruby192/lib/ruby/1.9.1/syck/tag.rb:81 -
method `yaml
_as' not defined in Module
Exception `Gem::LoadError' at C:/Ruby192/lib/ruby/1.9.1/rubygems.rb:762
- Could
not find RubyGem test-unit (>= 0)

Exception `Gem::LoadError' at C:/Ruby192/lib/ruby/1.9.1/rubygems.rb:762
- Could
not find RubyGem sources (> 0.0.1)

GET http://rubygems.org/latest_specs.4.8.gz
Exception `Errno::EWOULDBLOCK' at
C:/Ruby192/lib/ruby/1.9.1/net/protocol.rb:135
- A non-blocking socket operation could not be completed immediately. -
read wou
ld block
302 Found
GET http://production.s3.rubygems.org/latest_specs.4.8.gz
Exception `Errno::EWOULDBLOCK' at
C:/Ruby192/lib/ruby/1.9.1/net/protocol.rb:135
- A non-blocking socket operation could not be completed immediately. -
read wou
ld block
304 Not Modified
Exception `NoMethodError' at
C:/Ruby192/lib/ruby/1.9.1/rubygems/specification.rb
:538 - undefined method `to_ary' for #<Gem::Specification name=rdiscount
version
=1.6.5>
Installing gem rdiscount-1.6.5
Exception `NoMethodError' at
C:/Ruby192/lib/ruby/1.9.1/rubygems/package/tar_inpu
t.rb:49 - undefined method `readpartial' for
#<Gem::package::TarReader::Entry:0x
2d565b0>
Exception `IOError' at C:/Ruby192/lib/ruby/1.9.1/rubygems/format.rb:50 -
closed
stream
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1
Temporarily enhancing PATH to include DevKit...
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/COPYING
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/README.markdown
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/Rakefile
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/bin
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/bin/rdiscount
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext/Csio.c
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext/amalloc.h
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext/basename.c
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext/config.h
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext/css.c
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext/cstring.h
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext/docheader.c
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext/dumptree.c
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext/emmatch.c
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext/extconf.rb
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext/generate.c
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext/html5.c
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext/markdown.c
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext/markdown.h
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext/mkdio.c
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext/mkdio.h
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext/rdiscount.c
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext/resource.c
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext/tags.c
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext/tags.h
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext/toc.c
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext/xml.c
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/lib
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/lib/markdown.rb
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/lib
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/lib/rdiscount.rb
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/man
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/man/markdown.7
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/man
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/man/rdiscount.1
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/man
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/man/rdiscount.1.ronn
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/rdiscount.gemspec
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/test
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/test/benchmark.rb
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/test
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/test/benchmark.txt
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/test
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/test/markdown_test.rb
Exception `Errno::EEXIST' at C:/Ruby192/lib/ruby/1.9.1/fileutils.rb:243
- File e
xists - C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/test
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/test/rdiscount_test.rb
C:/Ruby192/bin/rdiscount
C:/Ruby192/bin/rdiscount.bat
Building native extensions. This could take a while...
Exception `Gem::InstallError' at
C:/Ruby192/lib/ruby/1.9.1/rubygems/ext/builder.
rb:49 - extconf failed:

C:/Ruby192/bin/ruby.exe extconf.rb
checking for random()... *** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

Provided configuration options:
        --with-opt-dir
        --without-opt-dir
        --with-opt-include
        --without-opt-include=${opt-dir}/include
        --with-optException `Gem::Installer::ExtensionBuildError' at
C:/Ruby192/
lib/ruby/1.9.1/rubygems/installer.rb:483 - ERROR: Failed to build gem
native ext
ension.

C:/Ruby192/bin/ruby.exe extconf.rb
checking for random()... *** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

Provided configuration options:
        --with-opt-dir
        --without-opt-dir
        --with-opt-include
        --withERROR: Error installing rdiscount:
        ERROR: Failed to build gem native extension.

C:/Ruby192/bin/ruby.exe extconf.rb
checking for random()... *** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

Provided configuration options:
        --with-opt-dir
        --without-opt-dir
        --with-opt-include
        --without-opt-include=${opt-dir}/include
        --with-opt-lib
        --without-opt-lib=${opt-dir}/lib
        --with-make-prog
        --without-make-prog
        --srcdir=.
        --curdir
        --ruby=C:/Ruby192/bin/ruby
        --with-rdiscount-dir
        --without-rdiscount-dir
        --with-rdiscount-include
        --without-rdiscount-include=${rdiscount-dir}/include
        --with-rdiscount-lib
        --without-rdiscount-lib=${rdiscount-dir}/lib
C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:368:in `try_do': The complier failed
to genera
te an executable file. (RuntimeError)
You have to install development tools first.
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:435:in `try_link0'
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:440:in `try_link'
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:552:in `try_func'
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:797:in `block in
have_func'
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:693:in `block in
checking_for'
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:280:in `block (2 levels)
in postp
one'
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:254:in `open'
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:280:in `block in
postpone'
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:254:in `open'
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:276:in `postpone'
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:692:in `checking_for'
        from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:796:in `have_func'
        from extconf.rb:5:in `<main>'

Gem files will remain installed in
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount
-1.6.5 for inspection.
Results logged to
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdiscount-1.6.5/ext/gem_ma
ke.out

D:\Downloads\Ruby>

--
Posted via http://www.ruby-forum.com/.

And while we're at it, would you know why if I debug with the "slow"
debugger, I get these errors?

···

==========================================================================
ruby 1.9.2 debugger listens on port 49296
--- !ruby/exception:NoMethodError
message: undefined method `critical=' for Thread:Class
---
- C:/Program Files/NetBeans
6.9.1/ruby/ruby/debug-commons-0.9.5/classic-debug.rb:269:in `trace_off'
- C:/Program Files/NetBeans
6.9.1/ruby/ruby/debug-commons-0.9.5/classic-debug.rb:279:in `block in
read_command_loop'
- C:/Program Files/NetBeans
6.9.1/ruby/ruby/debug-commons-0.9.5/classic-debug.rb:275:in `loop'
- C:/Program Files/NetBeans
6.9.1/ruby/ruby/debug-commons-0.9.5/classic-debug.rb:275:in
`read_command_loop'
- C:/Program Files/NetBeans
6.9.1/ruby/ruby/debug-commons-0.9.5/classic-debug.rb:330:in `block in
<class:DC_DEBUGGER__>'

They get resolved when debugging with the "fast" debugger. This is the
reason why I had to start down that "fast debugger" path. Is this
related or should this be a different topic?

--
Posted via http://www.ruby-forum.com/.

Yes, I filled in the form and posted on the Google rubyinstaller group
yesterday.

···

--
Posted via http://www.ruby-forum.com/.

Ok, I followed Luis' instructions although I unzipped the DevKit right
over the Ruby192 install folder. I did NOT gem install these.

If that was the intention, that could have been outlined in the
instructions.

DevKit needs to be separated from Ruby, because it contains files that
could affect a normal functioning system like find.exe, It just need
to be installed so it gets added to the path during gem installation.

linecache-0.43-mswin32.gem
ruby-debug-base-0.10.3-mswin32.gem

These gems are not the ones used by ruby-debug19, also, you can't
manually install them as they depend on an active internet connection
to download ruby source headers and be able to compile.

The dev machine which has Visual Studio and the Ruby Fast Debugger has
these gems:

ruby-debug-base19-0.11.24
ruby-debug-ide-0.4.9

So I attempted a gem install of ruby-debug19. I attached the
gem-make.out and the mkmf.log files to this reply. And here is my
output.

=======================================================================
C:\Ruby192>gem install ruby-debug19 -phttp://web-proxy:8080
Temporarily enhancing PATH to include DevKit...
Building native extensions. This could take a while...
ERROR: Error installing ruby-debug19:
ERROR: Failed to build gem native extension.

C:/Ruby192/bin/ruby.exe extconf.rb
checking for vm_core.h... *** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

Provided configuration options:
--with-opt-dir
--without-opt-dir
--with-opt-include
--without-opt-include=${opt-dir}/include
--with-opt-lib
--without-opt-lib=${opt-dir}/lib
--with-make-prog
--without-make-prog
--srcdir=.
--curdir
--ruby=C:/Ruby192/bin/ruby
--with-ruby-dir
--without-ruby-dir
--with-ruby-include
--without-ruby-include=${ruby-dir}/include
--with-ruby-lib
--without-ruby-lib=${ruby-dir}/lib
C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:368:in `try_do': The complier failed
to genera
te an executable file. (RuntimeError)
You have to install development tools first.

It is clear here that it didn't find the tools needed to compile the
extension because you didn't properly install the DevKit.

Thanks guys.

I did my best to provide you with links and instructions where to put
what and how to install it successfully, yet however you neglected
these instructions and as result still having problems.

Please do not compare your Visual Studio installation or whatever
between machines, I can bet you're not installing the exact same
version of Ruby, and beause you aren't, the results are not
comparable.

Also, please read what I said about the gem versions, the attempts to
install manually/locally and the real need for an active internet
connection.

Please, also read some of the tutorials in the RubyInstaller wiki:

Pretty much lot of folks following these instructions had great
success installing Ruby and DevKit and lot of gems.

···

On Nov 15, 8:41 pm, Allan Chin <achin5...@hotmail.com> wrote:

--
Luis Lavena

I only copied the DevKit over the existing Ruby install because there
were a few blogs which mentioned to do that. But at any rate, I
installed the DevKit in a separate folder and installed it via the
"init" and "install" scripts. They worked ok, but the ruby-debug19 seems
to fail the same way.

Perhaps that article was quite old. When referring to articles on the
'web', please provide a link. Is hard to keep track of every single
article that gets published and I've been working on ensure everybody
is having the right information.

For example, last week I send emails and comments to some blog authors
to correct their errors in their blog posts.

That will make my job more easy.

By the way, the "smoke test", gem install rdiscount --platform=Ruby -phttp://web-proxy:8080fails the same way.

Please run the same command with debug mode enabled:

gem install rdiscount --platform=ruby --http-proxy http://web-proxy:8080
--debug -V

Note the that platform option is all lowercase and the proxy needs to
be your proxy including username and password.

Paste the output here so we can take a look

···

On Nov 16, 3:30 pm, Allan Chin <achin5...@hotmail.com> wrote:
--
Luis Lavena

-phttp://web-proxy:8080works fine when I install the uuid gem. And the
next time I run into a mis-informed article, I will provide the link.
But up to now there were many. Here's the output of the rdiscount debug
install.

It is clear that gems that do not require compilation do not fail in
your environment, so please keep reading.

C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:368:in `try_do': The complier failed
to genera
te an executable file. (RuntimeError)
You have to install development tools first.
from C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:435:in `try_link0'

For some reason you environment is unable to compile gems.

Please fill in the following google docs form:

Also, please post a message to RubyInstaller group.

http://groups.google.com/group/rubyinstaller

We found just 2 other users unable to compile gems and we would like
to know more about your environment details for us to be able to help
you better.

Thank you.

···

On Nov 16, 8:42 pm, Allan Chin <achin5...@hotmail.com> wrote:
--
Luis Lavena

Roger, that is DevKit.

Not going to provide another type of downloads. We already have lot of
confusion about what version of what to download and how to install.

···

On Nov 17, 9:06 am, Roger Pack <rogerpack2...@gmail.com> wrote:

@Luis maybe we should provide people of a zip that includes a working
gcc+ruby, so that when weirdness happens they can use it and (it
hopefully work).

--
Luis Lavena

Roger Pack wrote in post #962115:

==========================================================================

ruby 1.9.2 debugger listens on port 49296
--- !ruby/exception:NoMethodError
message: undefined method `critical=' for Thread:Class
---
- C:/Program Files/NetBeans
6.9.1/ruby/ruby/debug-commons-0.9.5/classic-debug.rb:269:in `trace_off'
- C:/Program Files/NetBeans

with 1.9.x Thread#critical= was removed
maybe 1.8.x would work?
@Luis maybe we should provide people of a zip that includes a working
gcc+ruby, so that when weirdness happens they can use it and (it
hopefully work).
-r

Roger - I don't think this is a version problem because on my other dev
machine with Visual Studio installed. I am able to successfully install
the fast debugger and with the same 1.9.2, those undefined methods get
resolved.

···

--
Posted via http://www.ruby-forum.com/\.

Hello Allan, please stop comparing your Visual Studio vs this
installation. The versions of Ruby and the configuration are not the
same.

You have not provided any information about the that specific Ruby
installation (where and how you got it) and if you're actually
compiling things with Visual Studio or not.

It is clear that compilation itself is not working on your
environment, which we need to investigate. I've requested you fill in
the form for us to look at environment variables that might be
affecting GCC. Did you complete it?

···

On Nov 17, 11:58 am, Allan Chin <achin5...@hotmail.com> wrote:

Roger Pack wrote in post #962115:

> ==========================================================================
>> ruby 1.9.2 debugger listens on port 49296
>> --- !ruby/exception:NoMethodError
>> message: undefined method `critical=' for Thread:Class
>> ---
>> - C:/Program Files/NetBeans
>> 6.9.1/ruby/ruby/debug-commons-0.9.5/classic-debug.rb:269:in `trace_off'
>> - C:/Program Files/NetBeans

> with 1.9.x Thread#critical= was removed
> maybe 1.8.x would work?
> @Luis maybe we should provide people of a zip that includes a working
> gcc+ruby, so that when weirdness happens they can use it and (it
> hopefully work).
> -r

Roger - I don't think this is a version problem because on my other dev
machine with Visual Studio installed. I am able to successfully install
the fast debugger and with the same 1.9.2, those undefined methods get
resolved.

--
Luis Lavena

Roger - I don't think this is a version problem because on my other dev
machine with Visual Studio installed. I am able to successfully install
the fast debugger and with the same 1.9.2, those undefined methods get
resolved.

If that's the case then you'll probably have to dig down deep into your
log files for linecache and try and reproduce the problem and see what
is going on.

···

--
Posted via http://www.ruby-forum.com/\.