Distributing a gem

I`m trying to distribute a gem but gem push is not available under
ubuntu. And uploading the gem to rubyforge seems not to work anymore
(at least I pushed the gem there yesterday and today it is still the
previous version).
Can anybody help me out?

I'm running Ubuntu 10.10, and my gem command does have push. The
rubygems1.8 package provides rubygems 1.3.7.

What version of Ubuntu are you running, and how did you install rubygems?

-Jeremy

···

On 10/20/2010 1:45 PM, Gonzalo Garramuno wrote:

I`m trying to distribute a gem but gem push is not available under
ubuntu. And uploading the gem to rubyforge seems not to work anymore
(at least I pushed the gem there yesterday and today it is still the
previous version).
Can anybody help me out?

I have 10.04 and gem from apt-get.

···

On 20 oct, 16:46, Jeremy Bopp <jer...@bopp.net> wrote:

What version of Ubuntu are you running, and how did you install rubygems?

-Jeremy

What do you get when you run gem --version? Ultimately, you may need to
install the latest version of rubygems yourself rather than rely on the
package:

gem update --system

Upgrading Ubuntu to 10.10 may also be a good option if you prefer to use
packages.

-Jeremy

···

On 10/22/2010 02:20 PM, Gonzalo Garramuno wrote:

On 20 oct, 16:46, Jeremy Bopp <jer...@bopp.net> wrote:

What version of Ubuntu are you running, and how did you install rubygems?

-Jeremy

I have 10.04 and gem from apt-get.