Deprecated functions in gemspec

In my gem, I am getting a bunch of deprecated calls and classes when installing, like:

/usr/lib/ruby/vendor_ruby/rubygems/defaults/operating_system.rb:10: warning: constant Gem::ConfigMap is deprecated

NOTE: Gem::Specification#rubyforge_project= is deprecated with no replacement. It will be removed on or after 2019-12-01.

I am worried about the rubyforge_project call, as some of the gems (mainly pdf-writer) I am relying on are no longer maintained. How should I go about fixing those warnings? Can someone update pdf-writer?

···

--
Gonzalo Garramuño

"""
How
should I go about fixing those warnings? Can someone update pdf-writer?
"""

You can, maybe...

5 May 2020 Sal 15:56 tarihinde gga <ggarra13@gmail.com> şunu yazdı:

···

In my gem, I am getting a bunch of deprecated calls and classes when
installing, like:

/usr/lib/ruby/vendor_ruby/rubygems/defaults/operating_system.rb:10:
warning: constant Gem::ConfigMap is deprecated

NOTE: Gem::Specification#rubyforge_project= is deprecated with no
replacement. It will be removed on or after 2019-12-01.

I am worried about the rubyforge_project call, as some of the gems
(mainly pdf-writer) I am relying on are no longer maintained. How
should I go about fixing those warnings? Can someone update pdf-writer?

--
Gonzalo Garramuño

Unsubscribe: <mailto:ruby-talk-request@ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-talk>

Quoting Dan Fitzpatrick (dan@eparklabs.com):

pdf-writer has not been updated in 11 years. I recommend you update
your code to use prawn.

Or hexapdf. I used both and they work quite nicely.

Sadly, bitrot is something against which there is no easy solution.

Carlo

···

Subject: Re: Deprecated functions in gemspec
  Date: mer 06 mag 20 12:48:19 -0600

--
  * Se la Strada e la sua Virtu' non fossero state messe da parte,
* K * Carlo E. Prelz - fluido@fluido.as che bisogno ci sarebbe
  * di parlare tanto di amore e di rettitudine? (Chuang-Tzu)