Configuring Textmate for Ruby 1.9.1

I had just installed Ruby 1.9.1 using MacPorts, but TextMate still
interprets Ruby 1.8.6.

I had gone into my Shell Variables under preferences and set the
following:

Variable: TM_RUBY
Path: ./opt/local/bin/ruby1.9 (install location of my Ruby 1.9.1
install).

I ran a program, it ran on Ruby 1.9.1. I un-checked the Shell Variable
preference; it ran on Ruby 1.8.6. I checked the setting and re-ran, got
a "Command Error at line 6" pointing to some file in /tmp.

Is this configured properly? If so, what's wrong?

If it's not, what's the proper configuration?

···

--
Posted via http://www.ruby-forum.com/.

I had just installed Ruby 1.9.1 using MacPorts, but TextMate still
interprets Ruby 1.8.6.

I had gone into my Shell Variables under preferences and set the
following:

Variable: TM_RUBY
Path: ./opt/local/bin/ruby1.9 (install location of my Ruby 1.9.1
install).

I ran a program, it ran on Ruby 1.9.1. I un-checked the Shell Variable
preference; it ran on Ruby 1.8.6. I checked the setting and re-ran, got
a "Command Error at line 6" pointing to some file in /tmp.

I just ran through these steps and everything worked fine for me.

The error you show comes from where TextMate first invokes TM_RUBY. Are you sure you just checked and un-checked the box? If you edited the contents, you may have made it invalid with an extra quote or something. Just a thought.

Is this configured properly? If so, what's wrong?

If it's not, what's the proper configuration?

You are doing it right, yes.

James Edward Gray II

···

On Aug 12, 2009, at 9:41 AM, Mike Agres wrote:

After the error appeared, I had edited the directory location, taking
out the ./ at the start. The error still appeared (though it seemed to
point to a different file in /tmp). I changed it back, same error
(again, different file in /tmp).

Should I just re-create the shell variable?

···

--
Posted via http://www.ruby-forum.com/.

Can you show me the contents that variable holds now, while it's failing?

James Edward Gray II

···

On Aug 12, 2009, at 10:26 AM, Mike Agres wrote:

After the error appeared, I had edited the directory location, taking
out the ./ at the start. The error still appeared (though it seemed to
point to a different file in /tmp). I changed it back, same error
(again, different file in /tmp).

Should I just re-create the shell variable?

Actually, no. I'm at work now (on a PC) and the Mac's at home.

James Gray wrote:

···

On Aug 12, 2009, at 10:26 AM, Mike Agres wrote:

After the error appeared, I had edited the directory location, taking
out the ./ at the start. The error still appeared (though it seemed to
point to a different file in /tmp). I changed it back, same error
(again, different file in /tmp).

Should I just re-create the shell variable?

Can you show me the contents that variable holds now, while it's
failing?

James Edward Gray II

--
Posted via http://www.ruby-forum.com/.

Tonight, or whenever it's convenient, is fine. :slight_smile:

James Edward Gray II

···

On Aug 12, 2009, at 10:34 AM, Mike Agres wrote:

Actually, no. I'm at work now (on a PC) and the Mac's at home.

Alright, here's the error I (still) get:

/tmp/temp_textmate.dLXXwJ: line 6: : command not found

My setting is as follows:

Variable: TM_RUBY
Value: ./opt/local/bin/ruby1.9

···

--
Posted via http://www.ruby-forum.com/.

. in a Unix path means "current directory" and that's not what you meant here. Try removing it and I suspect it will work just fine.

James Edward Gray II

···

On Aug 12, 2009, at 7:50 PM, Mike Agres wrote:

Alright, here's the error I (still) get:

/tmp/temp_textmate.dLXXwJ: line 6: : command not found

My setting is as follows:

Variable: TM_RUBY
Value: ./opt/local/bin/ruby1.9

That worked. Thanks James.

···

--
Posted via http://www.ruby-forum.com/.