Compile rmagick on win32

Want to compile the rmagick-1.9.3 on win32 to get the latest version
intstead of the pre-compiled gem :).

after run,
ruby extconf.rb --with-rmagic-dir=path to the ImageMagick dir
I could get the makefile, but when compile, the following eror come
out,

RMagick-1.9.3\ext\RMagick\rmagick.h(114) : error C2371: 'boolean' :
redefinition; different basic type

Have looked through the documentation, seems like no info on how to
compile on win32?
Any help? Thanks!

newbie wrote:

Want to compile the rmagick-1.9.3 on win32 to get the latest version
intstead of the pre-compiled gem :).

after run,
ruby extconf.rb --with-rmagic-dir=path to the ImageMagick dir
I could get the makefile, but when compile, the following eror come
out,

RMagick-1.9.3\ext\RMagick\rmagick.h(114) : error C2371: 'boolean' :
redefinition; different basic type

Have looked through the documentation, seems like no info on how to
compile on win32?
Any help? Thanks!

The windows.h file already defines a "boolean" type, so that would
explain the error. Try adding this to the extconf.rb file:

have_type("boolean")

Then, within rmagick.h, surround line 114 with "ifndef HAVE_TYPE" and
"endif".

I don't know if that's the only issue, but it should solve that one at
least.

- Dan

Daniel Berger wrote:

newbie wrote:
> Want to compile the rmagick-1.9.3 on win32 to get the latest version
> intstead of the pre-compiled gem :).
>
> after run,
> ruby extconf.rb --with-rmagic-dir=path to the ImageMagick dir
> I could get the makefile, but when compile, the following eror come
> out,
>
> RMagick-1.9.3\ext\RMagick\rmagick.h(114) : error C2371: 'boolean' :
> redefinition; different basic type
>
> Have looked through the documentation, seems like no info on how to
> compile on win32?
> Any help? Thanks!

The windows.h file already defines a "boolean" type, so that would
explain the error. Try adding this to the extconf.rb file:

have_type("boolean")

Then, within rmagick.h, surround line 114 with "ifndef HAVE_TYPE" and
"endif".

I don't know if that's the only issue, but it should solve that one at
least.

- Dan

Oh, it looks like there is no extconf.rb file. Just comment out lines
109-114 and see how it goes.

- Dan