Celerity with Watir

Hi,
I'm trying to use celerity in my Ruby scripts.
I have installed JRuby and Ruby but when I run a Ruby script that
includes Celerity I get this error:
Celerity only works on JRuby at the moment.

As it says on celerity web page it is possible to use celerity with
watir then I don't understand why I get this message.

Any idea?

···

--
Posted via http://www.ruby-forum.com/.

You need to call your Ruby script with JRuby.

If you have both Ruby and JRuby installed you need to invoke jruby directly.
By default the ruby executable is in your system path, but it is not default
in most jruby releases.

Alternatively the RVM (Ruby Version Manager) receives strong praise for
handling these issues quite well.

···

On Wed, Nov 24, 2010 at 11:53 AM, Mario Ruiz <tcblues@gmail.com> wrote:

Hi,
I'm trying to use celerity in my Ruby scripts.
I have installed JRuby and Ruby but when I run a Ruby script that
includes Celerity I get this error:
Celerity only works on JRuby at the moment.

As it says on celerity web page it is possible to use celerity with
watir then I don't understand why I get this message.

Any idea?

--
Posted via http://www.ruby-forum.com/\.

--
http://richardconroy.blogspot.com | http://twitter.com/RichardConroy